You are viewing the PKP Support Forum | PKP Home Wiki

Cant add repositories to system

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Cant add repositories to system

Postby mica78 » Tue Jul 18, 2006 6:05 am

I just installed Harvester 2. The installation was far from easy, since only the third time it really passed on ok. It didnt give me any error messages though, so I dont know what was the problem.

Now the system is up and running, but I cant add any repositories to it.
When I enter the OAI URL and press save I get browser error saying "error loading web page" and the systems halts.

Any help with this one?
Posts: 19
Joined: Wed Aug 03, 2005 3:48 am

Postby asmecher » Tue Jul 18, 2006 9:01 am

Hi mica78,

Could you provide some details on the problems you encountered during installation and your server platform? I suspect that the problem (perhaps affecting both installation and and adding archvives) is a timeout. Try increasing your max_execution_time and max_input_time parameters in php.ini and restarting Apache. If this doesn't work, feel free to contact me with some details on the OAI repository you're having trouble with; I'll do some further testing to determine what the problem is.

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby kyle » Fri Oct 06, 2006 10:24 am


I had similar problem and found the solution in the docs/FAQ.

The short version of the solution is that you have to add "AcceptPathInfo On" to the httpd.conf file. Then restart Apache web server for the change to take effect.

There are more details in the docs/FAQ.

I hope that helps,
Posts: 2
Joined: Fri Oct 06, 2006 10:16 am

Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: Bing [Bot] and 1 guest