OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



User gets logged off spontaneously

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

User gets logged off spontaneously

Postby alanmarch » Fri Mar 02, 2012 6:42 am

Hi. I have a user reporting he gets logged out spontaneously every now and then. I guess the problems related to the fact that the user is in Argentina and the system is hosted in the US, and it's a timeout or network problem. Is there any way of preventing this to happen (extending timeout periods or overcoming network interruptions or whichever the cause)?

Many thanks and congrats to the developers of this fine software.

AM
alanmarch
 
Posts: 3
Joined: Fri Mar 02, 2012 6:32 am

Re: User gets logged off spontaneously

Postby asmecher » Fri Mar 02, 2012 11:26 am

Hi AM,

Have you tried disabling the session_check_ip option in config.inc.php, if it's not already disabled? If he's behind a proxy bank, he may appear to occasionaly change IP address to an outside observer.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8673
Joined: Wed Aug 10, 2005 12:56 pm

Re: User gets logged off spontaneously

Postby alanmarch » Fri Mar 16, 2012 12:05 pm

I let some time pass and the problem seems to be limited to one user in one particular place (not dependent on his machine but rather on the local network into which he is connected). I followed your advice but it didn't seem to fix the problem. Anyway....it is only limited to one user and he still can connect from other places, so I can bear with the problem for now ;-). I'll keep trying to trace the problem and will get back to you should I notice anything pertinent to the problem.

Thanks!
alanmarch
 
Posts: 3
Joined: Fri Mar 02, 2012 6:32 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest