OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problem with Link / Button names

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problem with Link / Button names

Postby StephenMiller » Mon Jun 26, 2006 6:34 am

I have a problem with all pages now displaying the names of all links in the following form:

##user.userHome##

What have I done? And how do I restore the pages to looking as they should?

Thanks,
Stephen
StephenMiller
 
Posts: 5
Joined: Tue Jun 13, 2006 5:49 am

Postby asmecher » Mon Jun 26, 2006 10:06 am

Hi Stephen,

Did you modify the locale file, e.g. locale/en_US/locale.xml? If this key is the only thing missing, you've likely removed the key or changed the key name.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8570
Joined: Wed Aug 10, 2005 12:56 pm

Postby StephenMiller » Tue Jun 27, 2006 5:37 am

asmecher wrote:Hi Stephen,

Did you modify the locale file, e.g. locale/en_US/locale.xml? If this key is the only thing missing, you've likely removed the key or changed the key name.

Regards,
Alec Smecher
Open Journal Systems Team


I simply cannot remember what I did but it is evident that I somehow reset or deleted a value. It was certainly changed using the admin screen (given that I do not remember what I did, better to say that whatever was changed was changed using the www interface as I have no access to the pc housing OSJ).

Stephen
StephenMiller
 
Posts: 5
Joined: Tue Jun 13, 2006 5:49 am

Postby asmecher » Thu Jun 29, 2006 11:52 am

Hi Stephen,

If you email me the link to your journal, I can check whether or not the locale file has been modified. I can provide suggestions thereafter. Off the top of my head, you shouldn't be able to cause this sort of problem through the admin interface.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8570
Joined: Wed Aug 10, 2005 12:56 pm

Postby StephenMiller » Fri Jun 30, 2006 4:45 am

asmecher wrote:Hi Stephen,

If you email me the link to your journal, I can check whether or not the locale file has been modified. I can provide suggestions thereafter. Off the top of my head, you shouldn't be able to cause this sort of problem through the admin interface.

Regards,
Alec Smecher
Open Journal Systems Team


Once again, thanks for the swift reply. it is one of the (many) reasons why we chose OJS for our pilot journal, that there was an effective and helpful support forum in place.

I copied across a fresh copy of \locale\en_US\local.xml and everything was back to normal (phew! as I am demo'ing the journal on Monday to visitors...)

I cannot remember exactly what I now did to cause this situation which is quite worrying as somehow you can blunder into it.

Stephen
StephenMiller
 
Posts: 5
Joined: Tue Jun 13, 2006 5:49 am

Postby asmecher » Fri Jun 30, 2006 7:58 am

Hi Stephen,

I'm scratching my head over this -- but nothing is coming to mind, and nobody as far as I know has run into a situation like this before. Glad to hear the journal is now working, and please let us know if you are able to clarify the situation.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8570
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests