OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Help for Installation Problems?

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

Help for Installation Problems?

Postby Philz » Thu Jun 29, 2006 11:45 am

New installation. Using php 4.4.2. After install, get the following message:

Warning: filemtime(): open_basedir restriction in effect. File(/locales.xml) is not within the allowed path(s): (/dh/web/phpmyadmin:/tmp:/usr/local/tmp:/dh/solidclient:/usr/local/lib/php:/myhomepath) in /myhomepath/harvester/classes/i18n/Locale.inc.php on line 258
Unknown cache type ""!

Anyone seen this before. Solution? I can edit the path of /locales.xml in Locales.inc.php so that it is found and in the allowed path, but it looks like variables are not being passed for that path and the cache type in Locale.inc.php.

Any help would be appreciated.

Phil
Philz
 
Posts: 4
Joined: Thu Jun 29, 2006 11:26 am
Location: Carlisle, Massachusetts

Postby asmecher » Thu Jun 29, 2006 12:44 pm

Hi Phil,

Have you modified your installation of OJS? That line number doesn't appear to have anything that would trigger the problem. However, it looks like you're missing some information from your configuration file; the locales.xml file should be in your registry path, as configured in the registry_dir directive of config.inc.php. Check to see that the registry path is properly set -- generally as follows:
Code: Select all
; Path to the registry directory (containing various settings files)
; Although the files in this directory generally do not contain any
; sensitive information, the directory can be moved to a location that
; is not web-accessible if desired
registry_dir = registry
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8314
Joined: Wed Aug 10, 2005 12:56 pm

Postby Philz » Thu Jun 29, 2006 1:31 pm

Thanks, Alec. I haven't modified the installation and the registry path is set to the default "registry" in the config file. But somehow the variables are not being passed. Changed the location for the config file, but that just gave me a message that the config file was missing. Any other ideas?

Thanks,

Phil
Philz
 
Posts: 4
Joined: Thu Jun 29, 2006 11:26 am
Location: Carlisle, Massachusetts

Postby asmecher » Thu Jun 29, 2006 2:02 pm

Hi Phil,

Odd; off the top of my head, it looks as though your system is having trouble parsing the configuration file. At least two of the directives (the registry path and the cache type) are not being set. Try placing the following near the top of your index.php to ensure that all error messages are being displayed:
Code: Select all
ini_set('display_errors', E_ALL);
Were you able to complete the installation process without problems? Does the config.inc.php configuration file appear corrupted in any way?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8314
Joined: Wed Aug 10, 2005 12:56 pm

Postby Philz » Fri Jun 30, 2006 8:45 am

I decided to scrap the first installation and reinstall and everything seems to be working now. Thanks, Alec for your help.

Thanks,

Phil
Philz
 
Posts: 4
Joined: Thu Jun 29, 2006 11:26 am
Location: Carlisle, Massachusetts

Postby asmecher » Fri Jun 30, 2006 9:05 am

Glad to hear it, Phil -- if you do manage to shed some light on what happened with the first installation, please post it here.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8314
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 2 guests

cron