OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Fake (spam bot?) users

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Re: Fake (spam bot?) users

Postby risehigh » Thu Feb 10, 2011 4:08 am

Hi Rick

CAPTCHA setting is simple.

For Example if you have OJS on in "http://localhost/OJS-234/"

Then

1. in this directory "http://localhost/OJS-234/" you can find config.inc.php

2. make a new directory for free font as:
"http://localhost/OJS-234/font/freefont/"

3. now keep the downloded free font file : "FreeSerif.ttf" here as:

"http://localhost/OJS-234/font/freefont/FreeSerif.ttf"

4. make in CAPTCHA just ON as below
; Whether or not to enable Captcha features captcha = On

5. Give the CAPTCHA font location (and keep the downloaded FreeSerif.ttf file here) as: "http://localhost/OJS-234/font/freefont/FreeSerif.ttf"

Goodluck

-Rise
=========================================
PS: The CAPTCH seetitting will be as below in REd Colour:
(Please replace http://localhost to your server name)

;;;;;;;;;;;;;;;;;;;;
; Captcha Settings ;
;;;;;;;;;;;;;;;;;;;;

[captcha]

; Whether or not to enable Captcha features
captcha = On
; Whether or not to use Captcha on user registration
captcha_on_register = On

; Whether or not to use Captcha on user comments
captcha_on_comments = On

; Font location for font to use in Captcha images
font_location = "http://localhost/OJS-234/font/freefont/FreeSerif.ttf"

;;;;;;;;;;;;;;;;;;;;;
risehigh
 
Posts: 12
Joined: Fri Feb 04, 2011 11:38 pm

Re: CAPTCHA not working...

Postby roxanneoconnell » Wed Apr 13, 2011 7:33 pm

I did what Rick suggested to the letter... and (pun quite intended) I do not see any image in Safari but I do get an image missing symbol (?). In Firefox it has text "Validation image".

This will at least stop the spambots... however it will also stop legitimate registrants.

Here is my config code

;;;;;;;;;;;;;;;;;;;;
; Captcha Settings ;
;;;;;;;;;;;;;;;;;;;;

[captcha]

; Whether or not to enable Captcha features
captcha = on

; Whether or not to use Captcha on user registration
captcha_on_register = on

; Whether or not to use Captcha on user comments
captcha_on_comments = on

; Font location for font to use in Captcha images
font_location = .../font/FreeSerif.ttf

I also tried the path = .../ojs/font/FreeSerif.ttf and = /nyscaproceedings.org/ojs/font/FreeSerif.ttf

I really need help here... thanks in advance.
Roxanne
roxanneoconnell
 
Posts: 11
Joined: Sat Apr 09, 2011 12:30 pm

Re: Fake (spam bot?) users

Postby ramon » Thu Apr 14, 2011 5:43 am

Dear Roxanne,

Make sure you have the font available.
FreeFont does not come as a default font in some systems.
If you don't have permission to install a new font [apt-get install FreeFont, in Linux/Debian/Ubuntu like servers], then you'll need to look for available true-type fonts [ttf extension].
ramon
 
Posts: 940
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Fake (spam bot?) users

Postby roxanneoconnell » Mon Apr 18, 2011 4:22 pm

Hi,
I do have the font and it's in the folder... what my hosting server does not have is IMLIB support because it's a unix platform. So I'm not sure why an open source system would do that. Is there a captcha function available without involving MicroSoft?

Roxanne
roxanneoconnell
 
Posts: 11
Joined: Sat Apr 09, 2011 12:30 pm

Re: Fake (spam bot?) users

Postby asmecher » Mon Apr 18, 2011 5:03 pm

Hi Roxanne,

imlib is open-source, and is available for UNIX platforms as well as Windows and others.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9072
Joined: Wed Aug 10, 2005 12:56 pm

Re: Fake (spam bot?) users

Postby jmacgreg » Sat Apr 23, 2011 11:53 am

Hi Roxanne,

You can also try our new reCaptcha plugin -- you can get the source for that here: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=4082. Please note that it hasn't yet been fully tested.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Fake (spam bot?) users

Postby coreysh » Tue Aug 30, 2011 5:43 pm

Just want to confirm that this post's solution worked on Windows with Apache web server!!!

The only things that I had to "pay attention" to were:
1. make sure I have the correct path, in my case it was font_location = "../ocs/font/FreeSerif.ttf"
2. restart the webserver to see the change

Thanks everyone for the help!!!


RickMath wrote::D :D :D
James and Tyler

Thanks for your input on resolving the issues. I am happy to report that the CAPTCHA feature is working as expected. The image is displayed with random letters and when they are entered everything works well. Time will tell if we are invaded with BOTs but so far none.

I suspect that the config.inc.php file specifies a higher level folder on a server. Maybe like the PKP one. Since I am on a shared server I had no control over the path to fonts nor could I install them in the usr folder.

So here was the solution that worked. I created a new folder in my OJS path called fonts. Using Tylers suggestion to upload the FreeSerif.ttf font file into this folder and repointing the captcha settings to this file with the path .../OJS/fonts/FreeSerif.ttf the captcha is working.

I have also done this in OCS and it works. The coding is slightly different as the path in our installation is ".../ocs/fonts...." instead of OCS (note case) and the path in ocs needs to have quotes.

So thanks to James and Tyler for a solution. The great thing about the PKP support forum is that with the people at PKP and us users we eventually work out a solution. It may take some time, but we always solve the issues.

Kudos everyone!

Rick
coreysh
 
Posts: 17
Joined: Tue May 10, 2011 12:19 pm

Re: Fake (spam bot?) users

Postby sswettenham » Thu Feb 02, 2012 10:52 pm

Solution:

1. Downloaded FreeSerif.ttf (ftp://ftp.gnu.org/pub/gnu/freefont/)
Note: used freefont-ttf.zip 1161 KB 05-04-07 12:00:00 AM
2. Created fonts subfolder (.../ocs/fonts)
3. Changed permissions on fonts folder and FreeSerif.ttf file to public read
3. Modified config.inc.php to include the following path
; Font location for font to use in Captcha images
font_location = /fonts/FreeSerif.ttf

Now working correctly with Open Conference Systems 2.3.4 (.tar.gz) (5164 KB).
Note: Font and folder seem to have been missing from the install package.
sswettenham
 
Posts: 1
Joined: Thu Feb 02, 2012 10:36 pm

Re: Fake (spam bot?) users

Postby asmecher » Fri Feb 03, 2012 3:38 am

Hi sswettenham,

We don't distribute any fonts with the system; they're typically available somewhere on the average server. (Their location is rarely standardized, so unfortunately users will have to go hunting a little.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9072
Joined: Wed Aug 10, 2005 12:56 pm

Previous

Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 3 guests