OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Message key not being displayed correctly

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Message key not being displayed correctly

Postby ramon » Wed Aug 31, 2011 7:00 am

Hello all,

In OCS 2.3.1, I've used the Customize Translation Plugin quite a bit.
Everything was working fine until yesterday.
The following key, ##reviewer.paper.reviewFormResponse.form.responseRequired##, which is translated in both regular and customized locale files, is being displayed as pasted, instead of the translation. This wasn't happening before and seems to be the only variable as such.
Anyone with a similar issue?
I couldn't find anything on the forum...
NOTE: The conference is online and reviewers are restless...
ramon
 
Posts: 945
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Message key not being displayed correctly

Postby JasonNugent » Wed Aug 31, 2011 8:13 am

Hey ramon,

If this particular key was working until yesterday, did someone edit your locale files and possibly break the XML or forget a " around an attribute or something?

Regards,

Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Message key not being displayed correctly

Postby ramon » Thu Sep 01, 2011 5:28 am

Hello Jason,

I don't have access to the server to check this directly, but editing the files via the interface of the Translation Plugin and the Customize Translation Plugin, both locale/locale.xml files apparently load correctly. I didn't go through all the files, but I don't think anyone edited the file directly.
The review process just started, so I can't be sure the problem was already happening.
Some reviewers are complaining and I don't know what could be wrong or how to start debugging this.
ramon
 
Posts: 945
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Message key not being displayed correctly

Postby jmacgreg » Fri Sep 02, 2011 10:37 am

jmacgreg
 
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am

Re: Message key not being displayed correctly

Postby jmacgreg » Fri Sep 02, 2011 10:38 am

(And http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6562, for anyone who's hitting the same problem in OJS.)
jmacgreg
 
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 1 guest