OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Layout Editor upload problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Layout Editor upload problem

Postby soj » Thu Jun 01, 2006 8:07 am

We recently enabled and assigned layout editing. However, we are no longer able to upload galley files. Previously the editors could upload files. Now we get a 404 forbidden error page. Something with permissions? I've searched the support archives and found references to permissions issues, but no details on what files to look at and what level to assign.

TIA ... soj
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby asmecher » Thu Jun 01, 2006 10:09 am

Hi Soj,

That's odd -- a 404 error page is a web server error, implying that the browser tried to go to a page that's not allowed. Could you send us a sample URL (e.g. changing your server name if it's not public) to the page that gives you the error?

Are you using OJS 2.1.0-1?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm

Postby soj » Thu Jun 01, 2006 10:36 am

Actually it's a 403 error - forbidden

http://www.ejssm.org/ojs/index.php/ejss ... LayoutFile
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby asmecher » Thu Jun 01, 2006 11:00 am

Hi Soj,

OJS itself never returns a 403, so I'm inclined to think that something more specific should appear in your PHP or web server error logs; alternately, try temporarily adding this to the top of your index.php:
Code: Select all
ini_set('display_errors', E_ALL);
This will cause any errors to be displayed in your browser (and shouldn't be left in place on a production system).

My best guess is that this was caused by a recent change in web server configuration.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm

Postby soj » Thu Jun 01, 2006 11:37 am

When I disable Layout Editing, I am able to upload files again as the editor.

I've turned on Apache error logging on my server but it may take up to 24 hours to be activated. ITMT, I'll try your suggestion.
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby soj » Thu Jun 01, 2006 11:51 am

Well, it's working now. Maybe it was a temporary server glitch. I made sure the files directory was writeable and that's all. Thanks for your time and sorry to have puzzled you with this one. soj
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby asmecher » Thu Jun 01, 2006 12:30 pm

Hi Soj,

Glad to hear it's working -- if you do manage to shed some light on what happened, please post the details here in case someone else runs into the same situation.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 5 guests