OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Proxy access denies login

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Proxy access denies login

Postby Bobby » Sun May 28, 2006 10:46 pm

Hi there

We have a user who repeatedly cannot login through her proxy (she's affiliated with a university). Her login keeps going back to a blank login page. This happens in both IE and Firefox. We've tried refreshing, clearing cookies, etc., but nothing works.


What can we do to help?

Thanks
Bobby
Bobby
 
Posts: 18
Joined: Sun Jan 08, 2006 4:19 pm
Location: Australia

Postby asmecher » Mon May 29, 2006 9:21 am

Hi Bobby,

Check your server log for error messages -- when OJS serves a blank page, it's usually an indication that a PHP error occurred. Post the message here and I'll suggest a work-around.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8426
Joined: Wed Aug 10, 2005 12:56 pm

Postby smcphill » Mon May 29, 2006 4:18 pm

Hi Alec,

I'm Bobby's sysadmin - there are no ojs-related entries in the apache error log. I can see POSTs being made by the client to the login resource though - below is a sample login attempt as logged by apache.

We're using php 4.3.11, apache 1.3.34, OJS 2.0.2.1.

The user account can be used to log in locally and from my home internet connection. The remote user in question has not been able to log in from her location using this proxy service using her own account or a test account.

Short of grabbing the POST data as it comes down, I'm not sure where to look next....

Code: Select all
XXX.XX.XXX.XX - - [28/May/2006:12:19:37 +1000] "GET /openpublish/index.php/jasal HTTP/1.0" 200 4680 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:19:38 +1000] "GET /openpublish/styles/common.css HTTP/1.0" 304 - "http://www.nla.gov.au/openpublish/index.php/jasal" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:19:38 +1000] "GET /openpublish/public/journals/1/journalStyleSheet.css HTTP/1.0" 304 - "http://www.nla.gov.au/openpublish/index.php/jasal" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:19:38 +1000] "GET /openpublish/js/general.js HTTP/1.0" 304 - "http://www.nla.gov.au/openpublish/index.php/jasal" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:19:38 +1000] "GET /openpublish/public/journals/1/homepageImage.jpg HTTP/1.0" 304 - "http://www.nla.gov.au/openpublish/index.php/jasal" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:20:15 +1000] "GET /openpublish/index.php/jasal/login HTTP/1.0" 200 5288 "http://www.nla.gov.au/openpublish/index.php/jasal" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:20:40 +1000] "POST /openpublish/index.php/jasal/login/signIn HTTP/1.0" 200 5413 "http://www.nla.gov.au/openpublish/index.php/jasal/login" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
XXX.XX.XXX.XX - - [28/May/2006:12:20:52 +1000] "POST /openpublish/index.php/jasal/login/signIn HTTP/1.0" 200 5413 "http://www.nla.gov.au/openpublish/index.php/jasal/login/signIn" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1)"
smcphill
 
Posts: 7
Joined: Thu Sep 01, 2005 6:24 pm

Postby asmecher » Mon May 29, 2006 4:55 pm

Hi smcphill,

In some cases, users browsing from behind proxy farms aren't able to log in because it appears to OJS as though they are connecting from several IP addresses; you can disable this security check by modifying OJS's config.inc.php file and turning off session_check_ip.

However, Bobby describes a blank page, which I think might be something different. PHP can log error messages to a number of different places, one of which is the Apache log -- have you checked to ensure that's where PHP is sending errors?

On second thought, perhaps by "blank page" the user was describing a blank login form; try disabling the option I mentioned above and see if that works.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8426
Joined: Wed Aug 10, 2005 12:56 pm

Postby smcphill » Mon May 29, 2006 5:12 pm

Hi Alec,

We're actually seeing a single IP address in the logs - I've made the change to the session parameter in the config.inc.php, so we'll see if that makes a difference.

I've just checked the php config, and its little wonder there aren't any logs - this install doesn't have error logging enabled :/

If changing the session config doesn't work, I'll get the user to try to log on to another version on a box where php is logging.

And I think Bobby would have meant a blank logging form rather than a totally blank page.

thanks!

Steve
smcphill
 
Posts: 7
Joined: Thu Sep 01, 2005 6:24 pm

Postby smcphill » Mon May 29, 2006 5:27 pm

Case closed - disabling the ip check in config.inc.php did the trick.

thanks again
smcphill
 
Posts: 7
Joined: Thu Sep 01, 2005 6:24 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests