OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



CC-BY logo on SSL site causes mixed-content

OJS development discussion, enhancement requests, third-party patches and plug-ins.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

CC-BY logo on SSL site causes mixed-content

Postby MartinEve » Mon Jul 11, 2011 1:52 am

At present, enabling the Creative Commons display will break OJS instances which run on full SSL.

For the reference of anybody who wants a quick fix, I've patched my local install using:

Code: Select all
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./locale/hr_HR/locale.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/eu_ES/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/it_IT/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/ja_JP/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/ro_RO/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/fa_IR/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/de_DE/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/pt_BR/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/nl_NL/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/en_US/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/no_NO/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/pt_PT/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/cs_CZ/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/zh_CN/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/fr_CA/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/es_AR/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/ru_RU/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/el_GR/common.xml
perl -pi -w -e 's/http:\/\/i.creativecommons.org/https:\/\/i.creativecommons.org/g;' ./lib/pkp/locale/es_ES/common.xml


I would suggest, though, that in future versions the ssl version is either included by default, or some selection based on protocol is used.
MartinEve
 
Posts: 11
Joined: Sun Jul 10, 2011 6:33 am

Re: CC-BY logo on SSL site causes mixed-content

Postby mcrider » Thu Jul 14, 2011 10:32 am

Hi Martin,

Thanks, I've added this to the bug report at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6620.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC


Return to OJS Development

Who is online

Users browsing this forum: No registered users and 3 guests