OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS 2.3.4 PDF not displaying

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Re: OJS 2.3.4 PDF not displaying

Postby jmacgreg » Sat Apr 02, 2011 9:44 am

Hi all,

Luciano -- are you experiencing this problem with any other PDFs? How many? I took a quick look at your back-issues, and it seems that a number of PDFs are behaving properly. You may just have to reupload that one, or at the very least check what it looks like on the server side.

Katrin -- unfortunately, we don't communicate privately unless it's a paid consultation -- if you are interested in that, please see our rates at http://pkp.sfu.ca/commercial.

Everyone else -- this thread revolves around two separate problems. Luciano's problem is that at least one PDF is appearing garbled/is being mihandled when viewed, whereas as far as I can tell everyone else is experiencing a problem with the way PDFs are being viewed. Please note that seeing a note similar to what jaik_70 wrote ("This PDF file you selected should load here ... etc.") is normal: users see this if they don't have a PDF plugin installed in their browser. If you are running into this problem and you are absolutely sure that your browser can display inline PDFs -- that is, if you've tested it with another PDF page, and it works fine -- please let us know, and include a link to your site, so we can also test.

I've also added a feature request for an additional direct-link-to-PDF configuration option to our bug tracker, here: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6565. Please feel free to CC yourself to the report for future updates.

Cheers,
James
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am

Re: OJS 2.3.4 PDF not displaying

Postby raickonen » Mon Apr 04, 2011 12:15 pm

I found 8 articles only in this journal:

http://seer.ufrgs.br/movimento.

I will check more details and will post here.

Tks for your answer.

Luciano
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS 2.3.4 PDF not displaying

Postby garde » Tue Apr 05, 2011 9:14 am

Hi all,

i had a similiar problem - the PDFs simply did not want to display.

After I while I figured out my problem.

If in the Setup under 4.3 "Custom identifiers will be used to identify published items." is checked, and the custom identifiers are somewhat obscure (my were something like "5(2): e10" ) an URL like the following is produced:

Code: Select all
http://www.xyz.net/ojs/index.php/ejhi/article/viewFile/5%282%29%3Ae10/69


and this fails - presumably because of the bracket, colon and/or space in it.

If I do not use these sustom identifiers, the PDF suddenly works fine:
Code: Select all
var success = new PDFObject({ url: "http://www.xyz.net/ojs/index.php/ejhi/article/viewFile/126/68" }).embed("articlePdf");


Hope this helps someone,
Cheers
Sebastian
garde
 
Posts: 17
Joined: Thu Mar 16, 2006 12:16 am

Re: OJS 2.3.4 PDF not displaying

Postby jaik_70 » Tue Apr 05, 2011 9:36 pm

Dear Sebastian

Thanks for sharing your experience. I do the same but PDF file is not displaying.

But the future solution suggested by James will provide a good strength to the OJS JM.

Here I like to inform that I checked this (OJS 2.3.4 PDF not displaying) on ISP Godaddy.
But on another ISP (Linux, cPanel) server "OJS 2.3.4 PDF displaying" fine on IE8 and Chrome.

-Jaik
jaik_70
 
Posts: 41
Joined: Tue Jun 02, 2009 5:49 am

Re: OJS 2.3.4 PDF not displaying

Postby raickonen » Wed Apr 06, 2011 12:41 pm

I tested another articles, in others journals and is working fine in alll browsers. My problem is justs this Journal(www.seer.ufrgs.br/movimento . Only old articles don't show, using Firefox and Chrome. Works well in IE8+.
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS 2.3.4 PDF not displaying

Postby raickonen » Mon May 02, 2011 11:00 am

Hi,

Any news about this problem, PDF?

My log error is:

WARNING: assert(): Assertion failed In file: xxxx/ojs/classes/template/TemplateManager.inc.php At line: 35 Stacktrace: Server info: OS: Linux PHP Version: 5.3.2-1ubuntu4.7ppa5~lucid1 Apache Version: N/A DB Driver: mysql DB server version: 5.0.77
database has produced an error Message: WARNING: assert(): Assertion failed In file: /xxxxxx/seer/ojs/lib/pkp/classes/template/PKPTemplateManager.inc.php At line: 61 Stacktrace: Server info: OS: Linux PHP Version: 5.3.2-1ubuntu4.7ppa5~lucid1 Apache Version: N/A DB Driver: mysql DB server version: 5.0.77


Still doesn't work in other browsers, just IE7+
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS 2.3.4 PDF not displaying

Postby jmacgreg » Tue May 03, 2011 12:46 pm

Hi raickonen,

Can you give us more information about whether your journal is using custom identifiers; and also, could you point to a specific article that doesn't appear to be working for you?

Cheers,
James
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am

Re: OJS 2.3.4 PDF not displaying

Postby raickonen » Thu May 12, 2011 5:35 am

This journal isn't using custom identifiers. All articles doesn't work, but you can see all articles here:

http://seer.ufrgs.br/Movimento/issue/view/1202/showToc

and

one article here(try to see with firefox, chrome and IE):

http://seer.ufrgs.br/Movimento/article/view/18216/11103
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS 2.3.4 PDF not displaying

Postby mcrider » Fri May 20, 2011 4:04 pm

Hi raickonen,

Can you post a screenshot of the galley layout page for that galley file (On the editing page for that submission, click on the 'edit' action for the PDF galley in question)?

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: OJS 2.3.4 PDF not displaying

Postby raickonen » Wed May 25, 2011 10:44 am

Hello Matt,

Can you explain better what kind of test must be done?
Apologize, but I really didn't understand what you asked.

This is an article on front page, where I have try edit it?

Cheers,

Luciano
raickonen
 
Posts: 34
Joined: Tue Nov 16, 2010 10:39 am

Re: OJS 2.3.4 PDF not displaying

Postby niemla » Wed Aug 03, 2011 6:41 pm

This sounds familiar. I upgraded from version 2.3.0.0 to 2.3.6.0 , and I can't automatically view PDF articles in any browser. You have to download them.

So this works:
blahblah.org/index.php/codex/article/download/39/76
But this does not:
blahblah.org/index.php/codex/article/view/39/76

Having to download files breaks up the user experience, and I've rolled it back to 2.3.0.0
Is there a patch for 2.3.6.0? I haven't been able to upgrade my OJS since 2009 :( :(
niemla
 
Posts: 7
Joined: Mon Sep 21, 2009 10:21 am

Re: OJS 2.3.4 PDF not displaying

Postby jmacgreg » Tue Aug 09, 2011 11:45 am

Hi niemla,

I don't quite understand what you're getting at here. OJS 2.3.3+ handles PDF display differently than older versions of OJS, but there's still an embedded PDF view option. You were never able to automatically view PDF articles in any browser before -- only browsers that supported inline PDF display -- and that remains true now. Could you expand on the problems you were seeing?

Cheers,
James
jmacgreg
 
Posts: 4162
Joined: Tue Feb 14, 2006 10:50 am

Re: OJS 2.3.4 PDF not displaying

Postby niemla » Tue Sep 20, 2011 8:30 pm

Thanks for asking. It's been a while since I could get back to this project.

I've resolved some server security problems with my webhost that were getting in the way. Now I've upgraded to 2.3.6.0 it's just the PDF display thing.
http://journal.acrlla.org/index.php/codex/article/view/32

Clicking on "PDF Full Text" doesn't load the PDF in the browser, you have to download it to see it.
The person in our group who has the editor's role will look at it tomorrow and see if there are any settings she can adjust to make it work.
niemla
 
Posts: 7
Joined: Mon Sep 21, 2009 10:21 am

Re: OJS 2.3.4 PDF not displaying

Postby niemla » Wed Sep 21, 2011 11:51 am

Or... OK, now the PDFs are working the way they're supposed to and the problem is solved. :shock:

I don't know what I did, though. It may be been changing the file permissions of the "js" folder, but I tried other things too so I'm not sure.

Well, either way, that's good! Thanks for you-all's help! :D
niemla
 
Posts: 7
Joined: Mon Sep 21, 2009 10:21 am

Re: OJS 2.3.4 PDF not displaying

Postby aruncs » Sun Apr 15, 2012 5:17 pm

Hi,
I have a problem with viewing the pdf directly embedded in the browser. I could view the pdf in Google Chrome, but it is not working on Firefox and Internet Explorer. I don't know why this happens. Whenever I open this with firefox or internet explorer, I get only a blank page I mean the pdf part. Could you please help me out with this issue as soon as possible.

Thanks
Arun
aruncs
 
Posts: 8
Joined: Sun Feb 19, 2012 1:18 pm

PreviousNext

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests