OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Section Editor cannot follow submissionReview

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Section Editor cannot follow submissionReview

Postby ernesto » Thu May 04, 2006 1:47 pm

Hello all:

We have a problem that can't solve by ourself.

Section Editors can not follow the links of the articles for submissionReview/*

We will appreciate your help.
Last edited by ernesto on Fri May 05, 2006 2:16 am, edited 1 time in total.
ernesto
 
Posts: 17
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain

Postby asmecher » Thu May 04, 2006 3:11 pm

Hi Ernesto,

Are these section editors assigned with access to the Review section of each assignment? As Editor, check the submission's Summary page and see if the "review" checkbox is checked.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Postby ernesto » Thu May 04, 2006 4:25 pm

asmecher wrote:Hi Ernesto,

Are these section editors assigned with access to the Review section of each assignment? As Editor, check the submission's Summary page and see if the "review" checkbox is checked.

Regards,
Alec Smecher
Open Journal Systems Team


To both questions the answer is "Yes". The Section Editor is assigned correctly and in the sumbission's Summary page the "review" and "editing" checkboxes are checked.

I logged in as the Section Editor and it is true, he can't follow the link.

Regards
ernesto
 
Posts: 17
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain

Postby asmecher » Thu May 04, 2006 5:37 pm

Hi Ernesto,

What happens when the section editor tries to follow the link? Could you post a copy of the link here (removing, if you prefer, your domain name etc.)?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Postby ppdm2 » Fri May 05, 2006 1:19 am

Hi,

I think I have the same problem than him. I use OJS v2.1.0-1.
When I'm logged as a section editor and I want to go to this link :
http://[...]/index.php/[journal]/sectionEditor/submissionReview/2
I arrived on a blank page.

And I noticed a strange thing :
I'm still logged as a section editor, in the "Use Home" page, and I click on "Section Editor". Then, I'm on the page "Submissions in Review".

But, above this title, I see this path:
Home > User > Editor > Submissions in Review

Why it's not "Section Editor" instead of "Editor" ?


This problem prevents me from knowing what is the role of a section editor.... :?

I hope what I said is understandable, thanks.
ppdm2
 
Posts: 4
Joined: Thu May 04, 2006 4:54 am

Postby ernesto » Fri May 05, 2006 1:38 am

asmecher wrote:What happens when the section editor tries to follow the link? Could you post a copy of the link here (removing, if you prefer, your domain name etc.)?



/var/log/apache2/access.log
xxx.xxx.x.xx - - [05/May/2006:09:50:01 +0200] "GET /ojs/index.php/conganat/sectionEditor HTTP/1.1" 200 19995


/var/log/mysql/mysql.log
The last query 3 lines as Section Editor are:

2058 Query SELECT * FROM sections WHERE journal_id = '1' ORDER BY seq
2058 Query SELECT * FROM article_email_log WHERE article_id = 14 ORDER BY log_id DESC
2058 Query SELECT review_id FROM review_assignments WHERE article_id = 14 and round = '1' AND (cancelled = 0 OR cancelled IS NULL) ORDER BY review_id

/var/log/mysql/mysql.log
The last query lines as Editor are:
2064 Query SELECT * FROM sections WHERE journal_id = '1' ORDER BY seq
2064 Query SELECT * FROM article_email_log WHERE article_id = 14 ORDER BY log_id DESC
2064 Query SELECT review_id FROM review_assignments WHERE article_id = 14 and round = '1' AND (cancelled = 0 OR cancelled IS NULL) ORDER BY review_id
==> /var/log/apache2/access.log <==
212.128.2.95 - - [05/May/2006:10:14:57 +0200] "GET /ojs/index.php/conganat/editor/submissionReview/14 HTTP/1.1" 200 17065
==> mysql.log <==
2064 Query UPDATE sessions
SET
user_id = '1',
ip_address = 'XXX.XXX.X.XX',
user_agent = 'Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060419 Firefox/1.0.8',
created = '1146815366',
last_used = 1146816897,
remember = 1,
data = 'userId|i:1;username|s:6:\"xxxxxx\";'
WHERE session_id = 'da056cfc32aad12a7e1057f8d9d83e01


/var/log/apache2/error.log
Allowed memory size of 8388608 bytes exhausted (tried to allocate 135 bytes)

...

/etc/php4/apache2/php.ini
I increased the size from 8MB to 10M.
Maximum allowed size for uploaded files.
upload_max_filesize = 10M

The problem persists

E. Moro Rodríguez
ernesto
 
Posts: 17
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain

Postby asmecher » Fri May 05, 2006 8:33 am

Hello all,

This is probably the key to solving the problem:
Allowed memory size of 8388608 bytes exhausted (tried to allocate 135 bytes)


Try increasing your memory_limit in your PHP configuration file (php.ini) to at least 12M; I usually use 16M and haven't had a problem. Make sure you restart your web server once you've modified php.ini.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7746
Joined: Wed Aug 10, 2005 12:56 pm

Postby ernesto » Fri May 05, 2006 9:36 am

asmecher wrote:Hello all,
Try increasing your memory_limit in your PHP configuration file (php.ini) to at least 12M; I usually use 16M and haven't had a problem. Make sure you restart your web server once you've modified php.ini.

Hi Alec,


:D
The problem it is solved.
Thanks a lot
ernesto
 
Posts: 17
Joined: Tue Dec 16, 2003 11:53 am
Location: Spain


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 5 guests