OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



2.3.1 won't upgrade or install

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

2.3.1 won't upgrade or install

Postby mwood » Mon Nov 01, 2010 6:50 am

Tried to upgrade 2.3.0 -> 2.3.1 but the upgrade tool failed. Only had one registered user (me) and no real customization, so I just dropped and recreated the database and went for a fresh install. No go: 'A database error has occurred: ERROR: relation "email_templates_default_email_key" already exists'.

PostgreSQL 8.4.4, PHP 5.3.3.

I was upgrading OHS with the hope of addressing the scads of PHP Warning and Deprecated messages I get in our daily harvest runs since the latest PHP upgrade. *sigh*
mwood
 
Posts: 20
Joined: Thu Nov 01, 2007 8:06 am
Location: Indianapolis, Indiana, US

Re: 2.3.1 won't upgrade or install

Postby jmacgreg » Wed Nov 03, 2010 9:54 am

Hi mwood,

You should be able to suppress those deprecated error messages -- see viewtopic.php?f=8&t=4957. If that's the only reason why you're upgrading, give it a shot; otherwise, let us know and we can take a closer look at the upgrade issue.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: 2.3.1 won't upgrade or install

Postby Alek » Tue Mar 15, 2011 11:28 am

Same error here from a clean install.
ini_set('error_reporting', 'E_ALL & ~E_NOTICE | E_STRICT'); do not let me install the Open Harvester System 2.3.1

PostgreSQL 8.1.22
PHP 5.1
Apache.

Thank You in advance.

Alek
Alek
 
Posts: 6
Joined: Fri Aug 28, 2009 1:23 pm

Re: 2.3.1 won't upgrade or install

Postby asmecher » Tue Mar 15, 2011 11:30 am

Hi Alek,

What error do you mean? If it's the message about the table already existing, it sounds to me like you're trying to run the install on a database that already contains tables.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: 2.3.1 won't upgrade or install

Postby Alek » Tue Mar 15, 2011 11:50 am

asmecher wrote:Hi Alek,

What error do you mean? If it's the message about the table already existing, it sounds to me like you're trying to run the install on a database that already contains tables.

Regards,
Alec Smecher
Public Knowledge Project Team


Hi asmecher!,

Yes, the error was: "'A database error has occurred: ERROR: relation "email_templates_default_email_key" already exists" but from a clean database.

I tried with the ohs 2.3.0 and no errors, only a minimal thing with the PKP logo (and maybe CSS).

There is a change log between 2.3.1 and 2.3.0?

Thank you!

Alek
Alek
 
Posts: 6
Joined: Fri Aug 28, 2009 1:23 pm

Re: 2.3.1 won't upgrade or install

Postby asmecher » Tue Mar 15, 2011 2:42 pm

Hi Alek,

What do you get on your new database if you run "\di"?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: 2.3.1 won't upgrade or install

Postby Alek » Wed Mar 16, 2011 12:39 pm

Excuse me asmecher, I don't understand where should I run "\di" and What should it return?

Thank you!

Alek
Alek
 
Posts: 6
Joined: Fri Aug 28, 2009 1:23 pm

Re: 2.3.1 won't upgrade or install

Postby asmecher » Wed Mar 16, 2011 3:03 pm

Hi Alek,

I presume you're running PostgreSQL -- run \di inside the PostgreSQL command-line client.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm

Re: 2.3.1 won't upgrade or install

Postby Alek » Thu Mar 17, 2011 1:15 pm

I Couldn't run that Alec I'm sorry.

I tried with the 2.3.0 version, and I had the same error here: viewtopic.php?f=4&t=4748

Finally I install 2.0.1 and It run very well.

I'll try to return to latest versions in a few days so I could try to discover the problem.

Thank you!!

Alek
Alek
 
Posts: 6
Joined: Fri Aug 28, 2009 1:23 pm

Re: 2.3.1 won't upgrade or install

Postby Alek » Thu Mar 17, 2011 6:56 pm

Alec, I think I found something...

In version 2.3.1 of OHS, In file \classes\install\Install.inc.php, in line 106,

Code: Select all
$role->setUserId($user->getId());


I think it should be:

Code: Select all
$role->setUserId($user->getUserId());


It is defined in line 46 of file: \lib\pkp\classes\user\PKPUser.inc.php

I'll try it tomorrow in a clean install.

Regards,

Alek
Alek
 
Posts: 6
Joined: Fri Aug 28, 2009 1:23 pm

Re: 2.3.1 won't upgrade or install

Postby asmecher » Fri Mar 18, 2011 8:39 am

Hi Alek,

In OHS 2.3.1, $user->getUserId() is a deprecated function and it calls $user->getId() anyway, so I don't think that's the problem. I suspect the problem is that you still have indexes in your database; just dropping the tables isn't enough. The \di command will list indexes so you can find out for sure. If you can't do that, try deleting and re-creating the database entirely rather than just dropping its contents.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9083
Joined: Wed Aug 10, 2005 12:56 pm


Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: Bing [Bot] and 0 guests