OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Help needed: problems after upgrade-RESOLVED

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Help needed: problems after upgrade-RESOLVED

Postby snermin » Wed Jul 14, 2010 1:27 pm

Hello,

Our Journal site has been doing well for more than a year. I decided to make an upgrade to 2.3.1.-2. using the full package method. Well it did not go as smooth as it used to in the last upgrade(s) and it ended up with Internal Server Error 500. I repeated the upgrade process with the error logging line added to index.php, however without log of a particular error sent back to browser.
I changed Installed parameter to "On" and apparently everything works well except article that have cover images attached to. When I click on the article link that does not have cover image article attached, everything works OK.
However, when I click on a link to article that has cover image, I get a blank page. With error logging on OJS reports the following error:

Fatal error: Call to undefined method PublishedArticle::getLocalizedHideCoverPageAbstract() in /hsphere/local/home/ukctz1/saliniana.com.ba/pages/article/ArticleHandler.inc.php on line 232

You may see the the TOC on [url]http://saliniana.com.ba/index.php?journal=ams&page=issue&op=view&path[]=4&path[]=showToc[/url]
and try to reproduce the error. Please, does anyone have any suggestion how to solve this issue. I do have the backup, but I don't have much experience in restoring the SQL databases and would prefer to correct this single problem, since everything else apparently works great.

At the end I would like to thank to the people behind this project since it facilitates the spread of the scientific knowledge.

Nermin Salkic
Bosnia
Last edited by snermin on Sun Jul 18, 2010 5:16 am, edited 1 time in total.
snermin
 
Posts: 12
Joined: Sat Dec 20, 2008 8:30 am

Re: Help needed: problems after upgrade

Postby snermin » Fri Jul 16, 2010 3:42 am

BUMP!

Anyone from PKP, please?
snermin
 
Posts: 12
Joined: Sat Dec 20, 2008 8:30 am

Re: Help needed: problems after upgrade

Postby snermin » Sun Jul 18, 2010 5:11 am

RESOLVED.

I deleted the call to the problematic procedure - we always include abstract in the article.
Everything works fine now.
snermin
 
Posts: 12
Joined: Sat Dec 20, 2008 8:30 am

Re: Help needed: problems after upgrade-RESOLVED

Postby lorenzoat » Wed Mar 02, 2011 8:47 pm

RESOLVED.

I deleted the call to the problematic procedure - we always include abstract in the article.
Everything works fine now.


Hi snermin

I have the same problem with my OJS installation. Can you tell me exactly what code line (and where) you deleted?...

Thanks a lot!!

Regards,
lorenzoat
 
Posts: 30
Joined: Sat Apr 10, 2010 9:41 am

Re: Help needed: problems after upgrade-RESOLVED

Postby asmecher » Tue Mar 08, 2011 2:20 pm

Hi all,

This is a known issue and has already been corrected in recent releases; see http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5730 for a patch.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 1 guest