OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problema con artículos tras una migración

Foro de soporte en español de Public Knowledge Project.

Moderators: jmacgreg, vlilloh

Forum rules
PKP se complace de proporcionar un foro dedicado a nuestros usuarios de habla española en todo el mundo.

Por favor, sea libre de hablar de cualquier aspecto acerca de Open Journal Systems; Open Conference Systems; Open Monograph Press; Open Harvester Systems; and Lemon8-XML; en este foro en español.

Tenga en cuenta que este foro está moderado por la comunidad, y no gestionado directamente por el equipo de desarrollo de PKP, aunque participen de vez en cuando.

Problema con artículos tras una migración

Postby acuartango » Wed Feb 02, 2011 8:42 am

Hola a todos,
a ver si alguien nos puede ayudar. Hemos migrado desde OJS 223 a OJS 2333 y los artículos que no estaban aún asignados a un nº de revista concreto, en la pantalla de edición, donde el editor agenda los artículos en nºs de la revista concretos, no se muestran más que los dos primero puntos, siendo imposible acceder a agendar ese artículo para su publicación en un número de la revista.

¿Alguna idea de cómo restaurar esos artículos?

gracias!
Aitor
Last edited by acuartango on Thu Feb 10, 2011 8:54 am, edited 1 time in total.
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby vlilloh » Sun Feb 06, 2011 11:14 am

Hola Aitor,

¿Podrías adjuntar una captura de pantalla de esos artículos en edición? ¿Los identificadores de los artículos te aparecen?

Saludos.
vlilloh
 
Posts: 276
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Problema con artículos tras una migración

Postby ymleon » Sun Feb 06, 2011 12:27 pm

Hola Aitor: Seria bueno si es posible me explicaras de que forma lograste migrar de una versión a otra, en mi casa he tratado de todas y no he logrado nada ...
Saludos
ymleon
 
Posts: 51
Joined: Tue Oct 07, 2008 8:32 am

Re: Problema con artículos tras una migración

Postby acuartango » Thu Feb 10, 2011 7:11 am

Hola, adjunto un pantallazo. Gracias por adelantado a todos.

aitor
Attachments
test.png
test.png (59.71 KiB) Viewed 3281 times
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby acuartango » Thu Feb 10, 2011 9:27 am

Para migrar a una nueva versión has de:

1.- Entra en OJS como administrador (primer usuario) y vete a la página de administración.
2.- Entra en "Información del sistema"
3.- En esta página puedes comprobar el estado de tu instalación en cuanto a versión. Si necesitas una nueva, te dejará descargar el PATCH que necesitas. Bájalo
4.- Copia el patch descomprimido en el directorio donde está la instalación de OJS
5.- Ejecuta desde ese directorio el siguiente comando, donde "PATCH_FILE" es el fichero que has bajado y copiado en el directorio de OJS:

$ patch -p1 < PATCH_FILE

6.- Ahora necesitas actualizar la base de datos a la versión que acabas de instalar con el siguiente comando(desde el directorio de OJS):

$ php tools/upgrade.php patch

Si te da algun fallo o no te actualiza ejecuta:

$ php tools/upgrade.php upgrade


Y listo, ya estás a la última! Comprueba que en la página de "Información del sistema" ahora te pone que estás a la última y listo.

También puedes actualizar de más formas, la documentación está accesible desde la página "Información del sistema". O en la web de OJS. Si necesitas más ayuda pregunta.

un saludo
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby vlilloh » Fri Feb 11, 2011 12:34 am

Hola acuartango,

Podemos probar a cambiar el artículo de estado. Ve a Summary, y archiva el envío. Una vez archivado coméntame si sale el resto de información que faltaba, también compruébalo cuando lo devuelvas a envíos activos.

También estaría bien que desde el Administrador limpiaras la caché de plantillas y de datos. Y que hicieras una revisión/reparación automática de la base de datos.

Saludos.
vlilloh
 
Posts: 276
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Problema con artículos tras una migración

Postby acuartango » Mon Feb 14, 2011 3:44 am

Muchas gracias por tu respuesta,
aunque sigue igual, lo he archivado y sigue cortándose la información en la pestaña "EDITING". Después lo he restaurado y tampoco se ha solucionado. Tampoco se ha solucionado limpiando las cachés.

gracias de nuevo, se agradecen las ideas.
aitor
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby vlilloh » Thu Feb 17, 2011 6:24 am

Hola Aitor,

El archivo /templates/sectionEditor/submissionEditing.tpl, ¿lo tienes correctamente?

¿Puedes revisar los siguientes archivos?
/templates/sectionEditor/submission/scheduling.tpl
/templates/sectionEditor/submission/layout.tpl
/templates/sectionEditor/submission/proofread.tpl

Saludos.
vlilloh
 
Posts: 276
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Problema con artículos tras una migración

Postby acuartango » Mon Feb 21, 2011 2:28 am

Gracias por tu respuesta.

He comparado los ficheros con los originales que he descargado de la web y son exactamente iguales. Además no sudece siempre, con todos los artículos. Parece como si algunos artículos antes de la migración se hayan quedado "corruptos" o en un estado raro...

Gracias por vuestra ayuda,
Aitor UPV/EHU
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby vlilloh » Mon Feb 21, 2011 3:12 am

Hola Aitor,

Parece ser que hay otros usuarios con tu mismo problema ahora mismo: http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=7054

En la actualización has perdido filas de la tabla signoffs que correspondían a esos envíos.

Si conservas la base de datos de la versión anterior, podrías ejecutar la sentencia
Code: Select all
SELECT * FROM signoffs WHERE assoc_id = 609

Esto correspondería por ejemplo para el envío de la captura de pantalla, el cual tiene id 609.

Y la misma sentencia para la base de datos de datos actual, y comprobar qué filas faltan en el envío de una base de datos a otra, y añadirlas en la base de datos actual.

Evidentemente, esto tendrás que hacerlo para cada envío en el que tengas este problema.

También proponen esta solución: http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=6450#p24830
Lo que sea más claro para ti.

Saludos.
vlilloh
 
Posts: 276
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Problema con artículos tras una migración

Postby acuartango » Mon Feb 21, 2011 8:35 am

He activado en php.ini "display_error = On", Y ahora puedo ver el error:

2. Author Copyedit
Fatal error: Call to a member function getDateNotified() on a non-object in ./cache/t_compile/%%B0^B03^B0335942%%copyedit.tpl.php on line 151

Y se corta aquí.

Me ha mandado un patch Edwin Chain, y parece que con ese patch funciona. Hago más pruebas y lo verifico, pero de momento parece que con el patch soluciono mi incidencia.

Mañana le pido permiso a Edwin para publicar su patch, o posteo la URL donde él lo publique.

Gracias a todos por vuestra ayuda!
aitor UPV/EHU Universidad del País Vasco
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby acuartango » Wed Feb 23, 2011 6:45 am

Pongo en enlace al mensaje que abrí en el foro en inglés:

viewtopic.php?f=8&t=7105&p=27847#p27847

Gracias de nuevo a todos,
aitor
UPV/EHU
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby rcanto » Thu Feb 24, 2011 6:35 am

Hola Aitor,

Yo estuve en la misma circunstancia, y lo que hice es utilizar una de las nuevos plugins que trae la 2.3.3.2, me refiero a la posibilidad de realizar una edición rápida agendando a un nº futuro y/o a un anterior si lo deseas, me refiero al Plugins QuickSubmit al que llegas desde el rol de administrador.

Eso sí, te asignará un nuevo número de registro al manuscrito, pero es muy efectivo. Y comprobarás que ya en este nuevo registro, si puedes editar sin que te salga el error que mencionabas. (Para una urgencia, no está mal)

Como en los ya publicados es posible que también siga saliendo el error al intentar editar, sin embargo en menor problema, pues la única cosa que se me ocurre, podría exigir una edición es para sustituir un documento publicado, al detectar una errata. Pues bien en ese caso la solución estaría en la navegación de ficheros, en donde teniendo como referencia los tres primeros dígitos del documento, puedes localizar el PUB y renombrarlo, subiendo el nuevo.

Espero haber aportado algo, yo llego desde el 10 de diciembre dandome de cabeza con la 2.3.3.2

Un saludo,
Ramón Cantó Alcaraz
http://www.ricyde.org
rcanto
 
Posts: 23
Joined: Sat Jan 15, 2011 3:42 am

Re: Problema con artículos tras una migración

Postby acuartango » Tue Mar 01, 2011 5:31 am

Gracias por la sugerencia, no conocía esa posibilidad.

De todas formas considerando las pruebas que hemos hecho, el parche de Edwin que está colgado en el thread en inglés, podemos decir que funciona perfectamente; mientras no saquen un parche oficial lo mantendremos.

Gracias a todos por la ayuda,
aitor - Universidad del País Vasco
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Problema con artículos tras una migración

Postby rcanto » Thu Mar 03, 2011 2:20 am

Hola Aitor,

Me gustaría preguntarte acerca de un problema que todavía no he conseguido solucionar, sobre todo para saber, si el parche edwin pudieran ser la solución para el caso, al no ser informático hay cosas que se me escapan. Te cuento:

Durante la gestión online de manuscritos, todo marcha bien, hasta que lo autores registrados, tras la comunicación mia como editor les digo, ya pueden ver las observaciones de los revisores, documentos que yo como editor, previamente he autorizado sean visibles para los autores, pues bien, cuando el autores entran en su pantalla y pinchan sobre el documento que está siendo evaluado, obtiene una pantalla interrumpida con el siguiente ERROR..

A continuación de los datos del envio, lo siguiente:
Estado
Estado En revisión
Iniciado 2011-01-01
Última modificación 2011-03-01

Envío de metadatos

Fatal error: Call to undefined method AuthorSubmission::getCopyeditorDateCompleted() in /home/5500/webs/cafyd.com/htdocs/REVISTA/ojs/cache/t_compile/%%0D^0D5^0D56FD2D%%metadata.tpl.php on line 9


Si os resulta familiar este error, y la solución fuera el parche Edwin, y me pudierais dar los pasos a seguir, teniendo en cuenta que no soy un experto en informatica, os lo agradeceria..

Gracias y cordial saludo,
Ramón Cantó Alcaraz
Universidad Politécnica de Madrid
http://www.ricyde.org
rcanto
 
Posts: 23
Joined: Sat Jan 15, 2011 3:42 am

Next

Return to PKP Soporte en Español

Who is online

Users browsing this forum: mikesoler and 1 guest