OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Another URL problem

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Another URL problem

Postby Banderson » Mon Jan 03, 2011 8:43 am

We're running OCS 2.3.3. In the admin settings, we've set the conference redirect to the only conference we're hosting in this instance. The base_url for the instance is:

http://conferences.library.gatech.edu/acsip

...which redirects to:

http://conferences.library.gatech.edu/a ... sip/ATLC11

Everything seems to be working fine; except that when a user clicks on "Subscribe" under the Notifications section, he or she receives an email to confirm at:

http://conferences.library.gatech.edu/a ... bscription

This URL is 404. I noticed that the confirmation URL doesn't include the "ATLC11", and so I tried adding it manually:

http://conferences.library.gatech.edu/a ... beMailList

This url does, indeed, go to the Notification Mailing List page; but generates an error:

"There was an error confirming your subscription."

We've had a few problems with generated urls in the past (in OJS, not OCS); but this doesn't seem to be the same thing. Any advice?

Thanks,

Bill
Banderson
 
Posts: 20
Joined: Tue Jan 22, 2008 8:24 am

Re: Another URL problem

Postby jmacgreg » Wed Jan 05, 2011 9:30 am

Hi Bill,

Thanks for this detailed report -- I've replicated the issue and have filed a bug report here http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6332. Please feel free to CC yourself to that report for future updates.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Another URL problem

Postby Banderson » Wed Jan 05, 2011 10:29 am

Thanks, James. It looks like Alec has identified this as a duplicate, and there is already a patch. I've installed the patch, and the subscription function is working perfectly.

Bill
Banderson
 
Posts: 20
Joined: Tue Jan 22, 2008 8:24 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest