OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Notification subscription problem

Are you a Director, Presenter, Reviewer or Conference Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael

Forum rules
This forum is meant for general questions about the usability of OCS from an everyday user's perspective: conference managers, presenters, and directors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OCS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OCS:

1. Read the documentation. We've written documentation to cover from OCS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OCS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OCS Technical Support subforum; if you have a development question, try the OCS Development subforum.

Notification subscription problem

Postby tonreproc » Thu Dec 30, 2010 2:00 am

Hi,

We have a problem with notification subscription. When an unregistered user subscribes for the notification list, then an email is sent with the two links. Both gave the 404 error message. After applying the 6262 patch (http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6262), the first link was in order, but the second one, for stopping receiving notification emails, still gave the 404 error.
Now I noticed that the path in both links is different, this is the text of the email message:
=======================================================================
You have signed up to receive notifications from ISG and ISARC Conferences.

Please click on this link to confirm your request and add your email address
to the mailing list:
//archweb1.bwk.tue.nl/isg-isarc2012/index.php/ISGISARC2012/ISGISARC2012/notification/confirmMailListSubscription/9c579d5e9f90672da2cb4e1a1445157a/c.pernot%40upcmail.nl

If you wish to stop receiving notification emails, please go to
//archweb1.bwk.tue.nl/isg-isarc2012/index.php/ISGISARC2012/notification/unsubscribeMailList
and enter your email address and password.

Your password for disabling notification emails is: xxxxx
========================================================================
(I skipped the http:// in the links to get the text of the link complete)

In the second link, the /ISGISARC2012 is mentioned once, as was the case in both links before applying the patch. Now the first link is all right but the second not.
I wonder what could be the reason for this. Any help would be appreciated.

BTW: I am using version 2.3.3-1 of the OCS and I applied all the recommended patches as mentioned in: http://pkp.sfu.ca/wiki/index.php/OCS_2. ... ed_Patches

Thanks,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Thu Dec 30, 2010 5:27 pm

Hi Cor,

Try applying the patch for http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5984 in the lib/pkp subdirectory. (Use the --dry-run option first, to make sure that it'll apply cleanly.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Sun Jan 02, 2011 3:33 am

Dear Alec,

thanks a lot for your suggestion. I did apply the patch you suggested and some error messages disappeared when subscribing and unsubscribing.
But, in the email I get from the system the second link, for stopping receiving notification emails, still returns a 404 error. I observe that in this second link the url is still missing the second '/ISGISARC2012'.
If I unscubscribe by hand, at the website, I can successfully unsubscribe with the password given in the e-mail. So we are close now I guess.
Any ideas?

BTW. Beside the suggested patches I also applied 5425, 5563, 5375 and now also 5984.

Cordial regards,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby tonreproc » Mon Jan 03, 2011 1:15 am

Dear Alec,

I need to rectify my remark about the applied patches.
Beside the suggested patches I only applied 6262 and now also 5984.

Regards,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Mon Jan 03, 2011 10:55 am

Hi Cor,

Try also the patch at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6323. It should correct the broken unsubscribe link. Does that cover all the issues you were experiencing?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Mon Jan 03, 2011 1:51 pm

Dear Alec,

I applied the patch 6323 and the link is OK now, but, if I subscribe first and then unsubscribe via the link in the e-mail, I get an error message:

"There was an error unsubscribing you. Please ensure your email address and password are correct."

If I unsubscribe by hand via the website, then I get the same error message. Before I applied this patch, I could unsubscribe OK via the manual method (not via the link).

So, is there still a loose end somewhere?

Cordial regards,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Mon Jan 03, 2011 3:35 pm

Hi Cor,

The patch for bug #6323 should only correct an incorrect link, i.e. the "unsubscribe" link previously went to a 404 and it should now to go the right unsubscribe code. Are you sure it has affected the manual method (i.e. without following the link in the email)?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Tue Jan 04, 2011 1:50 am

Dear Alec,

yes it does. I used a new e-mail address to subscribe. All went well. I then choose to unsubscribe by the manual method, using the password in the email, and I got the error message:
"There was an error unsubscribing you. Please ensure your email address and password are correct."

Next I used the link in the e-mail to unsubscribe, I got the same error message.

Regards,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Tue Jan 04, 2011 9:58 am

Hi Cor,

Is this a subscription you've already confirmed, or have you not yet confirmed the subscription (i.e. by clicking the link that comes in the email message)?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Tue Jan 04, 2011 11:01 am

Hi Alec,

yes, when I subscribed I used an e-mail address I did not use before (I thought that something could get mixed up by using the same email address again). Next I confirmed via the link in the e-mail message.
When I wanted to unsubscribe, I got the error message.

Regards,
Cor
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Tue Jan 04, 2011 11:36 am

Hi Cor,

Hmm, I'm having trouble duplicating this. What do you see in your notification_settings table with setting_value = the email address you just subscribed?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Tue Jan 04, 2011 11:57 am

Hi Alec,

is this what you mean:
Attachments
2011-01-04_195645.png
2011-01-04_195645.png (12.3 KiB) Viewed 2712 times
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Tue Jan 04, 2011 1:58 pm

Hi Cor,

Thanks -- and the contents of access_keys with context = 'MailListContext'? Best to not include key_hash since you're posting this publicly.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Re: Notification subscription problem

Postby tonreproc » Tue Jan 04, 2011 3:02 pm

Hi Alec,

here it is:
Attachments
2011-01-04_225744.png
2011-01-04_225744.png (46.72 KiB) Viewed 2707 times
tonreproc
 
Posts: 22
Joined: Sat Mar 06, 2010 8:56 am
Location: Netherlands

Re: Notification subscription problem

Postby asmecher » Tue Jan 04, 2011 4:19 pm

Hi Cor,

Hmm, everything there looks OK and I'm still having trouble reproducing the behavior locally. What is the URL that you're using for the "unsubscribe" form? Does the hash key in the unsubscribe URL match the one in the database (the one you obscured, with setting_id in notification_settings matching user_id in access_keys)? If you can, it would be helpful to see what's happening in lib/pkp/classes/notification/NotificationSettingsDAO.inc.php::unsubscribeGuest.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8860
Joined: Wed Aug 10, 2005 12:56 pm

Next

Return to OCS Conference Support and Discussion

Who is online

Users browsing this forum: No registered users and 1 guest