OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Multiple Custom Block issue on OCS 2.3.3.1

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Multiple Custom Block issue on OCS 2.3.3.1

Postby JohnGrobler » Tue Dec 14, 2010 1:13 pm

Good day,

We're running a new (non-upgraded) version of OCS 2.3.3.1. After adding more that one Custom Block instance on the /index.php/conf1/index/manager/plugin/generic/CustomBlockManagerPlugin/settings page and clicking save, still only one Custom Block instance is displayed on the Conference Style (step 4) page (/index.php/conf1/index/manager/setup/4). What actually happens is:

1) Custom Block A exist on Conference Style step 4.
2) I add Custom Block B on Custom Block Manager page.
3) When I return to Conference Style step 4, Custom Block A will be replaced by Custom Block B.

I've seen a similar issue reported for OJS here: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6076. The SQL command does however not work for OCS. After removing the non-existing columns form the SQL command and executing the query successfully (1 row added), the issue still remains. Please assist.

Thank you,
John Grobler
JohnGrobler
 
Posts: 51
Joined: Mon Dec 07, 2009 1:41 pm

Re: Multiple Custom Block issue on OCS 2.3.3.1

Postby jmacgreg » Thu Dec 16, 2010 2:38 pm

Hi John,

I'll ask one of our devs to get back to you on this. In the meantime -- have you attempted to patch your system with the OCS diff listed in Comment #10 of that report (https://github.com/pkp/ocs/commit/47b55 ... 81a39.diff is a direct link to the diff file), subsequently followed by re-running the upgrade script? If you haven't, give it a shot, but make sure you back your db up first, of course.

I've also run into another problem, most likely entirely unrelated to yours, but I'll reference it anyway: see http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6308.

Cheers,
James
jmacgreg
 
Posts: 4186
Joined: Tue Feb 14, 2006 10:50 am

Re: Multiple Custom Block issue on OCS 2.3.3.1

Postby JohnGrobler » Thu Dec 16, 2010 2:51 pm

Hi James,

Thank you for the feedback and link to the diff file. This is a new installation of OCS 2.3.3.1 (not upgraded). If I apply the patch to the inc and php files as described in the patch, should I run the DB upgrade script (staying on the same version of OCS) and will this script only upgrade database entries related to the custom block?

Thanks,
John Grobler
JohnGrobler
 
Posts: 51
Joined: Mon Dec 07, 2009 1:41 pm

Re: Multiple Custom Block issue on OCS 2.3.3.1

Postby jmacgreg » Fri Dec 17, 2010 4:32 pm

Hi John,

Yes, that's correct. We've done a fair bit of work to ensure that the upgrade process is idempotent -- that is, you should be able to run it repeatedly, and only those things that change will be accounted for. That said, it's always good to have a fresh backup before you do so.

Cheers,
James
jmacgreg
 
Posts: 4186
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests