OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



stage 1 submisson page missing bits in IE 6 & 8 ojs2.2.4

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

stage 1 submisson page missing bits in IE 6 & 8 ojs2.2.4

Postby omacneil » Mon Nov 15, 2010 10:01 pm

Running OJS 2.2.4 in both IE 6 & 8 the user (and me reproducing it) have the bottom part of the page / form not be visible. From the attached screendump you can see I am scrolled all the way to the bottom.

Firefox (at least on linux) has no problems.

Clearing caches in OJS has no effect.

Validator.w3.org says:

1. Line 248, Column 669: document type does not allow element "p" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag

…anguage:#0400;} --> <!--[endif]--> <p>You will complete the short bio which w…
[...]

Which looks serious.

I'm more inclined to think that I've messed with something by accident than that y'all haven't testing everything with Exploder.

We are running under $10 /month hosting so we have limits like no access to the apache log files and inability to delete files generated by the www-data (We do have a restricted shell)

A quick search of the forums on "checkbox" didn't show anyone else having this problem.

Any debugging guidance you could provide would be helpful
Attachments
ojs_2.2.4.0_win_ie8_no_cbox.png
screen shot of missing form elements
ojs_2.2.4.0_win_ie8_no_cbox.png (62.15 KiB) Viewed 717 times
omacneil
 
Posts: 7
Joined: Sat Apr 24, 2010 1:07 pm

Re: stage 1 submisson page missing bits in IE 6 & 8 ojs2.2.4

Postby jmacgreg » Wed Nov 17, 2010 11:36 am

Hi omacneil,

You can try this trick to force errors to the web page. (You'll want to turn this off once you've got the error.) You may also want to try removing or editing the checkbox item that seems to be choking, which you can do in Journal Setup Step 3.1, under Submission Preparation Checklist. If you still have problems after troubleshooting the checkbox item, could you post the HTML text of that item here? I may also try a test submission on your server.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: stage 1 submisson page missing bits in IE 6 & 8 ojs2.2.4

Postby omacneil » Wed Nov 17, 2010 8:23 pm

Thanks for your help, you gave us the answer.

It looks like the problem was a bad paste from MS Word:

Pasted below is the html / from the html view of the editor.

<!--[if gte mso 9]><xml> Normal 0 false false false </xml><![endif]--><!--[if gte mso 9]><xml> </xml><![endif]--> <!--[if gte mso 10]> <mce:style><! /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman"; mso-ansi-language:#0400; mso-fareast-language:#0400; mso-bidi-language:#0400;} --> <!--[endif]-->
<p> text of checkbox description </p>

It may be that this sort of thing is causing problems for other people.

I'm guessing you don't validate HTML from logged in users ...
omacneil
 
Posts: 7
Joined: Sat Apr 24, 2010 1:07 pm

Re: stage 1 submisson page missing bits in IE 6 & 8 ojs2.2.4

Postby jmacgreg » Thu Nov 18, 2010 2:05 pm

Hi omacneil,

Glad to hear the problem has been solved! OJS does strip unauthorized/suspicious HTML from non-authorized users (eg. authors; reviewers; readers) but not necessarily from journal managers or editors.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am


Return to OCS Technical Support

Who is online

Users browsing this forum: bardoo, Google [Bot] and 1 guest