OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installation problems

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Installation problems

Postby blinks » Mon Aug 09, 2010 11:54 pm

I've successfully installed OJS on a Windows machine, but am having trouble on a LInux box. After extracting the files to my desired location and changing file permissions (all to 777 in my frustration!), when I try to open my web browser, a blank screen (firefox) or 500 error (IE) displays.

Any suggestions?

TIA
blinks
 
Posts: 6
Joined: Mon Aug 09, 2010 11:48 pm

Re: Installation problems

Postby blinks » Tue Aug 10, 2010 6:14 pm

Well, I've got a bit further on; the problem was that some of the files still did not have the right permissions, despite my thinking they did. Having fixed that, I'm now still stuck at a blank screen, but with a different error - "Cannot redeclare class Locale in /var/www/html/ojs/classes/i18n/Locale.inc.php ".

I'm using PHP 5.3.1, and the archives tell me that I should "disable the internationalization extension in PHP"; however, I don't know how to do that. Doesn't seem to be anything relevant in php.ini.

Can anyone further advise?

TIA

p.s. we don't seem to have the i18n extension installed; at least, it isn't showing up in phpinfo
blinks
 
Posts: 6
Joined: Mon Aug 09, 2010 11:48 pm

Re: Installation problems

Postby blinks » Tue Aug 10, 2010 9:18 pm

Have done a temporary workaround of the Locale issue by globalling changing all instances of "class Locale ", "Locale::" and "Locale ::" to "class LocaleX" etc.

This got rid of the fatal Locale error. Then came a timezone warning, which I fixed by adding date_default_timezone_set('mycountry/mylocale') to index.php.

But I'm still getting a blank page, and there are no more error messages to help me along. I've got stacktrace turned on in config.inc.php, and have added ini_set('display_errors', E_ALL); to index.php. But nothing is displaying, not the tiniest little error message, and neither Apache's error_log nor access_log are throwing up errors.

There is one change; the address bar now says http://mydomain/ojs/index.php/index/install.

By the way, this in a linux installation; had no problems at all installing on a Windows machine.

TIA
blinks
 
Posts: 6
Joined: Mon Aug 09, 2010 11:48 pm

Re: Installation problems

Postby blinks » Thu Aug 12, 2010 5:00 pm

OK, finally, progress! Here's what I had to do to get the installation screen finally displaying. Note that I'm using Linux, PHP 5.3.1 and trying to install OJS version 2.3.2.1.

* Globally change all instances of class Locale to class LocaleX. More specifically -
- do a find/replace on all files to change Locale:: to LocaleX::
- do a find/replace on all files to change Locale :: to LocaleX :: (note the space)
- change name of class Locale to class LocaleX in classes/i18n/locale.inc.php - 1 instance (don't get confused with class Locale references in commented out fields
- change 'Locale' to 'LocaleX' in /lib/pkp/classes/i18n/PKPLocale.inc.php - 1 instance, line 222 (version 2.3.2.1)

* set display_errors=On in config.inc.php (this is off by default in 2.3.2.1 and most definitely needs to be mentioned in the wiki. Would have saved me days of frustration!!). Should also set show_stacktrace = On.

* ensure permissions are set properly; at this stage, I've set security to rwxrwxr_x for all directories/files, except for /public, /cache, config.inc.php which I've set to rwxrwxrwx. I'll backtrack on some of those permissions later when everything is working.

Note that I haven't yet progressed this particular installation beyond successfully displaying an install screen.

And I know there is supposed to be an easier way to get around the "Locale" issue than the find/replace I've done; but I have no idea what that is.
blinks
 
Posts: 6
Joined: Mon Aug 09, 2010 11:48 pm

Re: Installation problems

Postby mcrider » Mon Aug 16, 2010 11:00 am

Hi blinks,

We are aware of this problem and are working on it: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5240. Probably an easier solution is to just disable the new internationalization extension that ships with PHP 5.3.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Installation problems

Postby blinks » Mon Aug 16, 2010 2:17 pm

Thanks Matt, I was aware that disabling the internationalization feature was supposed to be a fix. But don't know how - there is nothing seemingly relevant in my php.ini. Advice on how to do this would be most useful.

TIA
blinks
 
Posts: 6
Joined: Mon Aug 09, 2010 11:48 pm

Re: Installation problems

Postby ubaiddev » Mon Apr 08, 2013 3:26 am

mcrider wrote:Hi blinks,

We are aware of this problem and are working on it: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5240. Probably an easier solution is to just disable the new internationalization extension that ships with PHP 5.3.

Cheers,
Matt


How can I disable internationalization extension. please guide.

Thanks
ubaiddev
 
Posts: 27
Joined: Mon Apr 08, 2013 1:35 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 3 guests