OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Language attribute forgot in Native import/export pluguin?

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Language attribute forgot in Native import/export pluguin?

Postby Marc » Wed Mar 08, 2006 12:47 pm

Hi folks,

I’m using the native importexport pluguin and I’ve had troubles importing the attribute « language » of an article.

Seeking in the code, I’ve found the attribute « language » is used for a supplementary file, but it doesn’t for an article.

I’ve found anything in the CVS about some change concerning this issue.

Finally, I’ve added the next patch (in ./ojs-2.0.2-1/plugins/importexport/native/NativeImportDom.inc.php) and that works for me:

if($lang = $articleNode->getAttribute('language')) $article->setLanguage($lang);

What do you think about that?

Cheers!

Marc
Marc
 
Posts: 34
Joined: Thu Jul 07, 2005 5:16 am
Location: Barcelona

Postby asmecher » Wed Mar 08, 2006 1:51 pm

Thanks, Marc -- this will be included in the next incremental release. For the bugzilla entry and a link to a patch, go to http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2100.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8844
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], mchladek and 8 guests