OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



assigning a user to multiple roles

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

assigning a user to multiple roles

Postby waynej » Wed Mar 01, 2006 6:56 am

I used to be able to assign users to multiple roles but I can't seem to do that any more. I can assign a user to a role when the user is first created but I can't add additional roles to that user.
At this point, when I really need to modify or add user roles, I do it directly in the database.
Am I missing something?

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm

Postby asmecher » Wed Mar 01, 2006 9:57 am

Hi Wayne,

To add additional roles to a user:
  • Log in as Journal Manager
  • Under Roles, choose the role you wish to enroll a user into
  • From the bottom of the page, choose "Enroll existing user"
  • Find the user and click the "Enroll" link

If these steps aren't working, please describe the problem in more detail.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Postby waynej » Wed Mar 01, 2006 10:08 am

Thanks, Alec.
I've identified the issue.
The steps you suggested are what I was doing with one exception.
After clicking on "enroll existing user" I would get about 20 pages of users so I would search for the user or use the alpha keys to narrow down the list.
Once I found them, I would click "enroll" but they wouldn't be enrolled.
I just tried paging through the users and that worked.
So I guess the answer is that you cannot search for the user, you have to page through until you locate them.

Thanks again.

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm

Postby asmecher » Thu Mar 02, 2006 10:16 am

Hi Wayne,

Could you verify that you're using the most recent release of OJS? IIRC, there was a bug similar to the one you mention in versions prior to OJS 2.1.0-1; however, this should be functioning in OJS 2.1.0-1.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Postby waynej » Thu Mar 02, 2006 10:26 am

Actually, no, we're still on 2.0.
We will be upgrading once we get a back-up server in place so that we can test the migration of our customizations.
Thanks again, Alec.

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests