OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



assigning a user to multiple roles

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

assigning a user to multiple roles

Postby waynej » Wed Mar 01, 2006 6:56 am

I used to be able to assign users to multiple roles but I can't seem to do that any more. I can assign a user to a role when the user is first created but I can't add additional roles to that user.
At this point, when I really need to modify or add user roles, I do it directly in the database.
Am I missing something?

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm

Postby asmecher » Wed Mar 01, 2006 9:57 am

Hi Wayne,

To add additional roles to a user:
  • Log in as Journal Manager
  • Under Roles, choose the role you wish to enroll a user into
  • From the bottom of the page, choose "Enroll existing user"
  • Find the user and click the "Enroll" link

If these steps aren't working, please describe the problem in more detail.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby waynej » Wed Mar 01, 2006 10:08 am

Thanks, Alec.
I've identified the issue.
The steps you suggested are what I was doing with one exception.
After clicking on "enroll existing user" I would get about 20 pages of users so I would search for the user or use the alpha keys to narrow down the list.
Once I found them, I would click "enroll" but they wouldn't be enrolled.
I just tried paging through the users and that worked.
So I guess the answer is that you cannot search for the user, you have to page through until you locate them.

Thanks again.

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm

Postby asmecher » Thu Mar 02, 2006 10:16 am

Hi Wayne,

Could you verify that you're using the most recent release of OJS? IIRC, there was a bug similar to the one you mention in versions prior to OJS 2.1.0-1; however, this should be functioning in OJS 2.1.0-1.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby waynej » Thu Mar 02, 2006 10:26 am

Actually, no, we're still on 2.0.
We will be upgrading once we get a back-up server in place so that we can test the migration of our customizations.
Thanks again, Alec.

Wayne
waynej
 
Posts: 20
Joined: Wed Feb 08, 2006 2:54 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests