OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Upload galleys in pdf

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Upload galleys in pdf

Postby Bobby » Tue Feb 14, 2006 5:49 pm

Hi there

We have successfully uploaded about four volumes of our journal but all of a sudden we have a problem: when uploading to galley format (a pdf because we're working with back copies), the system stops functioning. What are we doing wrong? I've tried a variety of options: uploading the layout file, a new file from my desktop (thinking that perhaps the original file is too far down the list of files and folders) - but nothing works.

Can you help?

Thanks
Bobby
Bobby
 
Posts: 18
Joined: Sun Jan 08, 2006 4:19 pm
Location: Australia

Postby asmecher » Tue Feb 14, 2006 6:07 pm

Hi Bobby,

Could you check what version of OJS you're using? Older versions of 2.x were missing an index, which caused full-text indexing to be very slow. Otherwise, could you describe what you mean by "the system stops functioning"?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8676
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bobby » Tue Feb 14, 2006 8:13 pm

Hi Alec

We're using Version 2.0.2.1

What I mean by 'stopping' is that the upload takes a very long time; only reaches half-way through the little indication box and then goes to an error page. I've asked our systems administsrator to have a look.

Thanks
Bobby
Bobby
 
Posts: 18
Joined: Sun Jan 08, 2006 4:19 pm
Location: Australia

Postby asmecher » Wed Feb 15, 2006 12:25 am

Hi Bobby,

That's probably the missing index during the full-text indexing process. Ideally, I'd suggest upgrading to OJS 2.1; however, you can also correct this by executing the following statement in MySQL:
Code: Select all
CREATE UNIQUE NDEX article_search_keyword_text ON article_search_keyword_list (keyword_text);

Submit the galley again and see if it works this time. Eventually, you'll probably have to re-generate the index; try running:
Code: Select all
php tools/rebuildSearchIndex.php
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8676
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bobby » Sun Feb 19, 2006 10:20 pm

Hi Alex

That's really helpful. We are planning to upgrade to the next version. I've passed on your comments to our systems administrator.

Thanks
Bobby
Bobby
 
Posts: 18
Joined: Sun Jan 08, 2006 4:19 pm
Location: Australia


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 3 guests