OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Logging in creates loop to login page

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Logging in creates loop to login page

Postby ItsDan » Thu Feb 05, 2009 12:03 pm

We've had a handful of users report that logging in loops them back to the login page. Repeated attempts produce the same result. I've yet to identify any commonality, we've had reports from both IE and FF users, PC and Mac, various different ISPs. AOL seems to come up more often than other ISPs, but they're not the only ones, and plenty of AOL users report no problem.

I haven't been able to replicate any of this behavior. Logging in from my own machine with their login credentials causes no problem. Have there been other reports of this? This isn't a new problem for us but I've been encouraged to try and track down the cause.
ItsDan
 
Posts: 54
Joined: Wed Jun 13, 2007 8:55 am

Re: Logging in creates loop to login page

Postby mcrider » Thu Feb 05, 2009 12:52 pm

Hi itsDan,

Is there anything non-stock about your OJS, e.g. have you made template modifications, or enabled SSL or mod_rewrite? Also, I noticed in your previous posts that you've tried to enable selective free access to users at registered Uni's and 3rd world countries--Could there be some bugs in those modifications? Finally, check to see if your users are using web accelerators (such as Google Web Accelerator), which have been known to cause problems with OJS.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Logging in creates loop to login page

Postby ItsDan » Thu Dec 03, 2009 2:22 pm

I thought I would revive this post. We recently upgraded to version 2.2.4, and we are still seeing this issue. I'm still having a hell of a time tracking it down, it seems to happen MORE for users of AOL, and I noticed a few with Safari, but I've also seen all the other major browsers and operating system. The described issue is basically that they attempt to login, and are redirected back to the login page without any error message. I've so far been entirely update to replicate this in any meaningful way. Some of these people then report the problem "fixes itself" at a later time, very baffling.

We also have a user who seems to be sent to the login page when they click the link sent using the "one click" review. I'm wondering if one of the developers can shed some light on whether that could be the same thing? I'm thinking a login credential (cookie, session, whatever) isn't being stored correctly so in both cases it's asking them to login.

I'm digging through the code but would love any other insight into what might cause this.
ItsDan
 
Posts: 54
Joined: Wed Jun 13, 2007 8:55 am

Re: Logging in creates loop to login page

Postby asmecher » Thu Dec 03, 2009 8:37 pm

Hi ItsDan,

Try disabling the session_check_ip option in config.inc.php.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8570
Joined: Wed Aug 10, 2005 12:56 pm

Re: Logging in creates loop to login page

Postby ItsDan » Fri Dec 04, 2009 9:20 am

Okay I've done so and will let you know if I have further issues. I should say I've also noticed a larger number of issues from people in developing nations, where they may have shared IP setups causing issues, here's hoping.
ItsDan
 
Posts: 54
Joined: Wed Jun 13, 2007 8:55 am

Re: Logging in creates loop to login page

Postby huwe » Fri Dec 18, 2009 4:24 am

Hi there,

we have the same problem with an OCS installation. Loggin in results in an endless loop of two different http requests. After stopping the loop the session is oviously established - so the user is actually logged in and can use the system properly. The same effect occurs if the user clicks on User Home and even if he tries to log out.

In our case the problem only occurs with FF. IE seems to work fine.

Another observation: The problem does only occur on conference level, i.e., when the user directly logs in to a conference or uses User Home for a conference. On the root level of the OCS installation login is possible without problems.

Trying to change the session_check_ip option in config.inc.php does not help in our case.

Are there any ideas what could cause this strange behaviour?

Best,
Uwe
huwe
 
Posts: 1
Joined: Fri Dec 18, 2009 4:09 am

Re: Logging in creates loop to login page

Postby jmacgreg » Tue Dec 22, 2009 3:01 pm

Hi Uwe,

Can you either post or PM me with a link to your site?

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Logging in creates loop to login page

Postby jmacgreg » Wed Jan 06, 2010 5:43 pm

Hi Uwe,

Thanks for the link, and the further information. I can't replicate locally or online. Do you see anything in your server's error log?

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Logging in creates loop to login page

Postby traue » Wed Feb 10, 2010 6:42 pm

Hi,

We are having the same problem.

Someone found a solution?



Regards,

Thiago G. Traue
traue
 
Posts: 25
Joined: Mon Mar 16, 2009 10:26 am

Re: Logging in creates loop to login page

Postby jmacgreg » Mon Feb 15, 2010 11:03 am

Hi Thiago,

Have you tried disabling the session_check_ip option, as mentioned above?

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Logging in creates loop to login page

Postby peterdietz » Mon Feb 15, 2010 12:18 pm

As recommended, setting session_check_ip = Off, has cleared up this issue for us. As we haven't been able to recreate the bug.

Another recommendation I have, is that in IE8, try going to developer tools (F12).
Change browser mode to IE8, and change document mode to IE8 Standards. Then restart IE8, possibly the computer, and retry.

That and if user's are able to, try using a better browser, such as Chrome or Firefox.
peterdietz
 
Posts: 12
Joined: Mon Feb 15, 2010 12:09 pm

Re: Logging in creates loop to login page

Postby traue » Mon Feb 15, 2010 12:50 pm

Hi,

Yes, I had turned this parameter and did not work.

I noticed something strange that causes the loop.

The loop (all users) occurs after a user as an administrator comes in, and login as another User ("login as" in the user List) and then logOff.
Then I try to make the logoff with my user and it is not completed and return to "User Home".

After a while (they probably when the session times out) when attempting to login with my User (the first) the loop begins to occur.
I thought initially it was a problem with permissions on files chache, but that's ok, even put 7777 in that folder, but the problem persists.


Regards,


Thiago G. Traue
traue
 
Posts: 25
Joined: Mon Mar 16, 2009 10:26 am

Re: Logging in creates loop to login page

Postby jmacgreg » Fri Feb 19, 2010 11:16 am

Hi Thiago, all,

Could you also check your browser's privacy settings? We've had reports that privacy settings higher than "Medium" create login problems as well.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Logging in creates loop to login page

Postby traue » Sun Feb 21, 2010 4:47 pm

Hi James,

I've already checked and the problem continues. I tried in Firefox, Chrome, and IE, all putting safety at least, the problem occurred.

The loop occurs between two pages:

www.lajss.org / index.php / LAJSS / user
and
www.lajss.org/index.php/LAJSS/login?source =% 2Findex.php% 2FLAJSS% 2Fuser

(for some reason, these pages alternate with each other endlessly, with blank pages)

lajss is the name of my journal, which i've set up to be the only one in config.ing.php:

Code: Select all
(...)
; The canonical URL to the OJS installation (excluding the trailing slash)
base_url = "http://www.lajss.org/"
base_url [LAJSS] = http://www.lajss.org/index.php/LAJSS

; Path to the registry directory (containing various settings files)
(...)


I also noticed that when someone presses the button logoff the same is not done and he is redirected to the "user home".

Any ideas? I'm thinking of re-installing, but I have no time and I would lose the articles under review / editing / ...


Regards,


Thiago G. Traue
traue
 
Posts: 25
Joined: Mon Mar 16, 2009 10:26 am

Re: Logging in creates loop to login page

Postby jmacgreg » Thu Feb 25, 2010 11:44 am

Hi Thiago,

Are you using mod_rewrite to rewrite the URLs? What about commenting out that second base_url configuration line so that you have

Code: Select all
    (...)
    ; The canonical URL to the OJS installation (excluding the trailing slash)
    base_url = "http://www.lajss.org/"
    ; base_url [LAJSS] = http://www.lajss.org/index.php/LAJSS

    ; Path to the registry directory (containing various settings files)
    (...)


I'm confused as to why that line may be there. Try it, quickly, but of course reinstate it if your install starts to go weird. Or fill me in on why you have the line there, if you can.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Next

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests