You are viewing the PKP Support Forum | PKP Home Wiki

##strings## in secondary language section

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

##strings## in secondary language section

Postby uxiopr » Sat Dec 26, 2009 12:37 pm

Hi (again), I have upgraded my OJS installation from 2.2.3 to 2.3.1 using the "full package" method, following the two steps of docs/UPGRADE (upgrading the files and the database).

The journal has two languages installed, Spanish (primary) and English. There is no problem with the spanish section, but with the english one.

Before the upgrade, on the navigation menu at the top of the page of the english section, instead of reading as it had prior to the upgrade (Home - About...) now it reads (there is various errors in another sections of the screen, see the rounded words):


Something similar in Editor home -> Submissions:


Have I done the upgrade correctly? I have done modifications to some files (after upgrading), but I do not think that they are the cause of this behaviour. I only made changes to:

- /syles/common.css (changing text size, colors...)
- config.inc.php (changing the smtp options)
- /plugins/blocks/navigation/block.tpl (adding some links and images)

Sorry for my english and thank you
Posts: 22
Joined: Thu Nov 19, 2009 10:36 am

Re: ##strings## in secondary language section

Postby jmacgreg » Wed Dec 30, 2009 12:42 pm

Hi uxiopr,

You may be missing some locale files on the server, which can sometimes happen thanks to a failed FTP upload. Take a look in locale/en_US/, and also in lib/pkp/locale/en_US, and ensure that all files from the package download are present. (This may also be the issue with viewtopic.php?f=8&t=5591&p=21213#p21213.)

Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am

Re: ##strings## in secondary language section

Postby uxiopr » Thu Dec 31, 2009 11:36 am

Thanks for the reply James. There were two 0-bytes files in that folders, I uploaded them again and... solved!

My another problem stills there (viewtopic.php?f=8&t=5591). I tried to upload again the content of /lib/pkp/classes/db/, but the error stills. I don´t know which files could be necessary to re-upload, could you give me any advice? Or can I re-upload the full package (excluding config.php.inc and /public)? If I re-upload the full package, is it needed to complete the final step of the installation (upgrading the database)?

Thanks a lot :)

Posts: 22
Joined: Thu Nov 19, 2009 10:36 am

Re: ##strings## in secondary language section

Postby uxiopr » Fri Jan 01, 2010 12:06 pm

Solved after reinstalling. Thanks for your help. :)
Posts: 22
Joined: Thu Nov 19, 2009 10:36 am

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests