OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Alternative to memory_limit

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Alternative to memory_limit

Postby magius » Sun Jan 22, 2006 2:21 am

Hi to all


Exist an alternative to resolve problem due to memory_limit = 8?

I do not have access to php.ini (hosting site)

TIA

magius
magius
 
Posts: 21
Joined: Thu Nov 17, 2005 11:28 am

Postby asmecher » Mon Jan 23, 2006 1:31 am

Hi magius,

Try adding this near the top of your index.php script:

ini_set('memory_limit','12M');

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Postby magius » Mon Jan 23, 2006 2:22 am

Thanks Alec

I have try but...

The problem persist (page blank at access) (ojs last version)
(the problem presented after 1 mounth after install, previous all ok)

I have added this:
ini_set('memory_limit','12M'); (near the top...)

and this
ini_set('memory_limit','16M');

But random (now yes, now no) the page it's blank

The view html code in blank page show only this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=utf-8"></HEAD>
<BODY></BODY></HTML>


Regards
and thanks, thanks, thanks

magius

LAST MINUTE
Added at end of index.php (before ?> )
ini_set("memory_limit", "16M"); (one space plus after , )

and now function - it's casual ?

Bye
magius
 
Posts: 21
Joined: Thu Nov 17, 2005 11:28 am

Postby asmecher » Mon Jan 23, 2006 11:40 am

Hi magius,

The problem likely isn't fixed... it's also possible that your host is running in safe mode, in which case many ini_set directives are ignored. I'm afraid you'll have to take this up with the server admin.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Postby magius » Mon Jan 23, 2006 11:53 am

Thanks Alec

Another little question

exist a mode for verify if host running in safe mode? (without ask at provider)


TIA

magius
magius
 
Posts: 21
Joined: Thu Nov 17, 2005 11:28 am

Postby asmecher » Mon Jan 23, 2006 12:04 pm

Hi magius,

To find out whether you're running in safe mode, create a PHP script called phpinfo.php containing:
Code: Select all
<?php
phpinfo();
?>

and point your browser to it. This gives you detailed information on the server's PHP configuration.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

Postby magius » Tue Jan 24, 2006 10:02 am

Hi Alec

Safe mode Off

:D

thanks again

magius
magius
 
Posts: 21
Joined: Thu Nov 17, 2005 11:28 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 2 guests