OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Illegal mix of collations

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Illegal mix of collations

Postby jgmorse » Fri Jan 20, 2006 1:09 pm

Hello. I have recently installed OJS 2.0.2.1 and created an issue to test drive the system. Everything went fine until I published the issue. Now when I click "Current Issue" I get the following error:

DB Error: Illegal mix of collations (utf8_general_ci,COERCIBLE) and (latin1_swedish_ci,IMPLICIT) for operation 'locate'

I made the changes to config.inc.php as detiled in http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=1640 (even though that's supposed to be fixed in this version anyway) and no improvement.

Any further leads would be appreciated.


OJS Version
Current version

2.0.2.1 (November 29, 2005 - 02:34 PM)


Version history

Version Major Minor Revision Build Date installed

2.0.2.1 2 0 2 1 2005-11-29




OJS configuration settings from config.inc.php.
general
installed On

registry_dir registry
session_cookie_name OJSSID
session_lifetime 30
scheduled_tasks Off
date_format_trunc %m-%d
date_format_short %Y-%m-%d
date_format_long %B %e, %Y
datetime_format_short %Y-%m-%d %I:%M %p
datetime_format_long %B %e, %Y - %I:%M %p
database
driver mysql


persistent On
debug Off
i18n
locale en_US
client_charset utf-8
connection_charset Off
database_charset Off
files

public_files_dir public
umask 18
security
force_ssl Off
force_login_ssl Off
session_check_ip On
encryption sha1
email
search
min_word_length 3
results_per_keyword 500
result_cache_hours 1
oai
oai On

interface
items_per_page 25
page_links 10
debug
show_stats Off
show_stacktrace Off
Server Information

Basic operating system and server software versions. Click on Extended PHP Information to view extended details of this server's PHP configuration.
OS platform Linux
PHP version 4.3.10
Apache version Apache/1.3.26 (Unix) PHP/4.3.10
Database driver mysql
Database server version 4.1.10a
jgmorse
 
Posts: 2
Joined: Thu Jan 12, 2006 4:00 pm

Postby asmecher » Fri Jan 20, 2006 1:31 pm

Hello jgmorse,

The problem originates in a character encoding mismatch in your database. Bug #1640 was fixed against OJS 2.1, so I don't think it's the cause of this problem; if you've migrated databases, upgraded the server, etc., this may be the cause.

I'd suggest trying the second approach mentioned in http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=1640#c1 -- set all your tables to UTF-8 and enable connection_charset and database_charset in OJS 2. Additionally, you might consider setting your MySQL default character set to UTF-8.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7745
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests