OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with "include"

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Postby asmecher » Mon Jan 02, 2006 12:17 pm

Hi Bacarozzo,

This would involve a lot of changes -- OCS was written before CSS was a commonly-used standard, and uses fixed-size HTML tables for layout. Making OCS use a more modern approach (CSS) would be very complicated; my suggestion is that you change the fixed table measurements, i.e.:
Code: Select all
<table border="0" width="400" cellpadding="2" cellspacing="0" border="0" cols="2">
...

to use relative measurements, i.e.
Code: Select all
<table border="0" width="90%" cellpadding="2" cellspacing="0" border="0" cols="2">
...


This will still involve a lot of fine-tuning, unfortunately. I haven't tested this with OCS to see what side-effects it causes, so please report your experiences here if you can.

Happy new year!
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bacarozzo » Tue Jan 10, 2006 6:34 am

Hello!!!

For the problem of the admin section i only comment the two rows added for the IIS problem (it is written in another topic).
I didn't get the iis problem so, and the admin section still work.
Chapter width:
i made as you said but i got some format problem. i must know i can make images of the "side template" adaptive for different resolution.
When i strech them some can't stretch more than some and the central table of every page still remain the same.
I don't need to change this characterist of the site so i don't know if i got much deeper into this argument.
I have so many tweaks to do that it's my last problem!
But if got something useful i surely post it here!
Bye
BACA
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby Bacarozzo » Thu Jan 12, 2006 5:22 am

Hello to everyone...i got a tweak to do but it is harder than others.
My professor want a scheduler that hasn't information about rooms and places.
I loaded all the information as "Additional Conference Functions".
When i try to unselect a room, the scheduler don't want to show the session that hasn't the location. I can't find the control that make this, so, how do i do?? Whitch code i must modify??
Thanks.
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby Bacarozzo » Thu Jan 12, 2006 8:53 am

I find a trick for the problem of the scheduler.
Now i got another problem.
The reviewers don't get any email.
I choose the option

submit full paper with abstract > review > post paper

Well, i'll try to explain all i get.

When i submit the abstract and the paper i recieve an email that notify the successfully submit.
Then i got the paper in the admin section.
I select a reviewer from the list and i assign him to the proposal.
The reviewer is always me with the same email address of the submitter or with another mail address. I don't recieve any mail that say me about the assignment of the review. If i get in the review section i can anyway review the paper.
I don't get the accept/refuse mail too!!!!!!!
Why???
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby asmecher » Thu Jan 12, 2006 4:30 pm

Hello Bacarozzo,

Have you manually sent the notification emails? See Conference Manager > Add/Edit Reviewers List > Preview and Send Notification Email.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bacarozzo » Fri Jan 13, 2006 2:06 am

In fact the question is: i must send the email manually??
In the doubt i tried & i didn't get any mail!!!
i re-tried as you said me but i didn't get the email!!!!
I didn't do any modification to the admin code except for the
cookie function (modification that i take away becouse it gave me that infamous warning of the header).
Where is the problem for You?
Thanks
Federico
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby Bacarozzo » Fri Jan 13, 2006 2:29 am

Another important thing!!!
I have a previous version, not modified, running on a Apache server.
It work properly, so, it could be a server problem (the actual version run on IIS).
Must i give you the url to test something???
Thanks again.
BACA
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby Bacarozzo » Fri Jan 13, 2006 4:34 am

3rd post...don't kill me Sir!

I got this problem, with the apache server version of OCS (the one that send mails properly!):

Code: Select all
Warning: date(): Windows does not support dates prior to midnight (00:00:00), January 1, 1970 in c:\wamp\www\lmcs06\reviews.php on line 586


This error is present whereever a date will show itself.
Where is the problem???
Thanks again and sorry again for the triple post!
BACA
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby asmecher » Fri Jan 13, 2006 12:08 pm

Hi Bacarozzo,

Ah -- you're running on Windows. In this case, you probably need to configure PHP's mail functions to use an external SMTP server. See http://ca.php.net/manual/en/ref.mail.php for the configuration directives you need -- particularly "SMTP".

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bacarozzo » Fri Jan 13, 2006 12:58 pm

Ok, but, for the date problem???
what should i do???
----- ------
I'm ALWAYS on a windows server...Apache is on a windows machine as well as IIS...could it be the server that influnces the mail sending??
The submission email is sent EVERY time!!
The others mails (reviewers, accept/refuse mails) NEVER!!
Which code i must modify???
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Postby asmecher » Fri Jan 13, 2006 2:31 pm

Hi Bacarozzo,

The date issue appears to come up when PHP's date() function is called with a bad parameter; your line numbers are different from the stock version of OCS (due to modifications, probably), but I suspect the line in question is in admin/reviews.php:
Code: Select all
Date submitted: ".date("F j, Y g:i A", timestamp2php($review_items[timestamp]))."</p>
Check in your database to see if there are items with a null timestamp; this should never happen.

For the email issue: If the system is able to send one message, it should be able to send all messages. I can only guess at what's happening, but here are two suggestions:
  • Check your SMTP server's log to see if it's unable to deliver messages for some reason.
  • Try setting up a stock version of OCS under IIS and see if it's able to deliver the messages; if it is, double-check your customizations.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm

Postby Bacarozzo » Fri Jan 13, 2006 2:57 pm

i have an idea...maybe it is crazy but...
i can try to do some kind of rollback...
let me explain it.

It seems like only admin emails are not sent ("comment posted" mails are sent and the script that send them isn't in the admin folder...)
So, i can make a backup of the admin files and try to overwrite the only ones that are not customized by the installation/set up. I mean, they are only a few, so i can get in a pre-modification state...obviously if the files i left aren't modified.
The problem is that i'm out of time, i cannot do anything this days and the server administrator can't help me so this is the fastest thing i can do to try something quickly, and i know that is bad too, but, as i said, i have no choise. Can You say me exactly which php files of admin folder are customized by installation/set up??

-----------------------------

Date() problem:

i get the error in other php files, exactly that line, the error i posted was of another file (i modified not so many scripts :roll: ...surely not the reviewer script!!!). Anyway U understand the problem perfectly.
I must check the database...and i'll do it as soon as i can, what i want to know is...if i fill the null values it can solve definitively or i must do other things to be quiet! :?
As always thanks for Your time and patience!
BACA

PS: i know, i made stupid question but i'm really new to PHP...:oops:
Bacarozzo
 
Posts: 17
Joined: Tue Dec 13, 2005 3:53 am

Previous

Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest