OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Error logging in using ssl in 1.1.6

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
This forum is meant for general questions about the usability of OJS from an everyday user's perspective: journal managers, authors, and editors are welcome to post questions here, as are librarians and other support staff. We welcome general questions about the role of OJS and how the workflow works, as well as specific function- or user-related questions.

What to do if you have general, workflow or usability questions about OJS:

1. Read the documentation. We've written documentation to cover from OJS basics to system administration and code development, and we encourage you to read it.

2. take a look at the tutorials. We will continue to add tutorials covering OJS basics as time goes on.

3. Post a question. Questions are always welcome here, but if it's a technical question you should probably post to the OJS Technical Support subforum; if you have a development question, try the OJS Development subforum.

Error logging in using ssl in 1.1.6

Postby jfenton » Thu Apr 22, 2004 12:56 pm

I've created a secured login page using the following rewrite rule:

RewriteRule ^/login.php$ https://www.ojs.university.edu/login.php [R,L]

This worked consistently in v.1.1.5, but when I upgraded to v.1.1.6 I sometimes get results like the following (from the ssl access logs):

192.168.108.208 - - [20/Apr/2004:17:23:16 -0400] "POST /login.php?op=login HTTP/1.1" 302 -
192.168.108.208 - - [20/Apr/2004:17:23:17 -0400] "GET /httpsadmin/user/index.php HTTP/1.1" 404 311

OR

192.168.108.208 - - [22/Apr/2004:15:48:32 -0400] "GET /login.php?op=login HTTP/1.1" 302 -
192.168.108.208 - - [22/Apr/2004:15:48:32 -0400] "GET /httpsadmin/editor/editor.php HTTP/1.1" 404 314

Any idea what's going on or how to fix it? Notice the additional "/https" prefixed to the base url
jfenton
 
Posts: 6
Joined: Tue Jan 13, 2004 4:53 pm
Location: Emory University Libraries

Postby kevin » Thu Apr 22, 2004 1:08 pm

There's a small bug in OJS 1.1.6 that will break HTTPS redirects. We haven't released a fixed version yet, but it's just a one line change in include/common.php:

Code: Select all
-       $baseurl = isset($_SERVER['HTTPS']) ? 'https' : 'http' . '://' . $_SERVER['HTTP_HOST'] . preg_replace('!/admin.*$!', '', dirname($_SERVER['SCRIPT_NAME'])) . '/';
+       $baseurl = (isset($_SERVER['HTTPS']) ? 'https' : 'http') . '://' . $_SERVER['HTTP_HOST'] . preg_replace('!/admin.*$!', '', dirname($_SERVER['SCRIPT_NAME'])) . '/';
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm


Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests