OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



registration.php not applying css header styles properly

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

registration.php not applying css header styles properly

Postby ChrisB » Fri Dec 30, 2005 12:12 pm

This is odd.

I have a (partial) implementation of OCS, and I've customised headers etc. For some reason the registration form part of registration.php is ignoring the following css stylesheet instruction:

Code: Select all
<style type="text/css">
 <STYLE>
 <!--
 A { text-decoration: none }
 -->
 </STYLE>


Also it will not apply this style in the header, despite it being included in the relevant theme.inc.php

Code: Select all
font class="WhiteText"


As a result, I'm getting header links with underlined text, but only on this page. The rest is fine.

I'm guessing it's something to do with this page being printed by a php script instead of html markup.

Is there a bit of code I could add to the php to correct this error?
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby asmecher » Fri Dec 30, 2005 12:43 pm

Hi Chris,

I don't think this is caused by PHP -- It's probably a typo in your CSS and/or HTML. For example, the following:
Code: Select all
<style type="text/css">
 <STYLE>
 <!--
 A { text-decoration: none }
 -->
 </STYLE>
should probably read
Code: Select all
<style type="text/css">
 <!--
 A { text-decoration: none }
 -->
 </style>


Try using the various validation tools available online:
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Postby ChrisB » Fri Dec 30, 2005 3:44 pm

:oops:

Ahem, yes it was a typo, or rather several. Sorry.
Everything is fine now.
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest