OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Invited speakers cannot submit (cookies again)

Are you responsible for making OCS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, John

Forum rules
What to do if you have a technical problem with OCS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved. Please note that this FAQ is OJS-centric, but most issues are applicable to both platforms.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OCS Conference Support and Discussion subforum; if you have a development question, try the OCS Development subforum.

Invited speakers cannot submit (cookies again)

Postby ChrisB » Thu Dec 22, 2005 5:07 pm

The problem this time is 'invitedsubmit.php'.

I set up an invited user, but can't login to submit abstracts/papers etc. Keeps looping back to login.

Tried the 'commenting out' trick but it just refused to recognise users.

How to solve?

Chris
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby ChrisB » Thu Dec 22, 2005 5:31 pm

Sorry, can login, but not submit...

So something is interfering with the "action=new" function of this script? I'm guessing a cookie issue?

Anyhow, if you have any tips they'd be most welcome!
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby ChrisB » Thu Dec 22, 2005 5:42 pm

Seems there was a TYPO. invitedsubmit.php calls "$action==new" instead of "$action=new" !!!!!!!

Case solved? I hope...

:wink:
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby ChrisB » Thu Dec 22, 2005 5:58 pm

Alas, now my users can fill out their abstracts in the text boxes, but still cannot submit abstracts or papers!

Should I just give up and use OJS instead? Or is there something simple I may be overlooking?

:(
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby asmecher » Thu Dec 22, 2005 7:01 pm

Hi Chris,

That line ($action=="new") is correct -- you shouldn't have to change it.

So far, it sounds like all the problems you're encountering are cookie-related; I suspect your cookie path is being set wrong and therefore OCS never receives the cookies it sets. Try to focus on that problem and see if it corrects the other problems.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8415
Joined: Wed Aug 10, 2005 12:56 pm

Postby ChrisB » Fri Dec 23, 2005 7:02 am

asmecher wrote:So far, it sounds like all the problems you're encountering are cookie-related; I suspect your cookie path is being set wrong and therefore OCS never receives the cookies it sets. Try to focus on that problem and see if it corrects the other problems.



Hi Alec,

Alas changing the 'match' requirement just broke the site:

Parse error: parse error, unexpected '/' in (*server-root-dir-details*)/ocs/admin/include/cookie.inc.php on line 56

Bah humbug!
ChrisB
 
Posts: 16
Joined: Thu Dec 22, 2005 12:25 pm

Postby asmecher » Fri Dec 23, 2005 11:06 am

Hi Chris,

Double-check your code; I think you've introduced a typo. If you like, post code snippets here for the changes you make.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8415
Joined: Wed Aug 10, 2005 12:56 pm


Return to OCS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest