OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Error message during OJS installation

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Error message during OJS installation

Postby george_guo » Sun Dec 18, 2005 8:33 pm

I got an error message when install OJS

Please see the error message below:



Object not found!
The requested URL was not found on this server. If you entered the URL manually

please check your spelling and try again.
If you think this is a server error, please contact the webmaster
Error 404
192.9.222.212
Sun 18 Dec 2005 19:32:02 CST
Apache/2.0.40 (Red Hat Linux)



We want to setup an OJS system in our LAN.
My system:
Redhat9.0+apache+MySQL+PHP, I installed apache+MySQL+PHP during Redhat9.0 installation.

I Extracted the OJS archive to the directory:
/var/www/html/111
and then
chmod -R 777 html
and then
Open IE in one machine in our LAN.
visit: http://192.9.222.212/111
(192.9.222.212 is IP address of the machine Redhat9)
But the address in IE go to: http://192.9.222.212/111/index.php/index/install
and then, I got the error message above.
Would you please show me what is the problem?
george_guo
 
Posts: 4
Joined: Sun Dec 18, 2005 5:27 am

Postby asmecher » Sun Dec 18, 2005 11:09 pm

Hello George,

This is most likely an Apache configuration problem -- check your settings and ensure that the AcceptPathInfo directive is enabled. See docs/FAQ.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Postby george_guo » Mon Dec 19, 2005 11:26 pm

Hi Alec Smecher
Thank you for your reply.
I donot think it is an Apache configure error problem.
I can install other BBS system on my system.
Do you have any other idea?
george_guo
 
Posts: 4
Joined: Sun Dec 18, 2005 5:27 am

Postby asmecher » Tue Dec 20, 2005 12:18 am

Hi George,

OJS uses URLs like the one you noted (http://192.9.222.212/111/index.php/index/install), where index.php is the name of the main PHP script, and /index/install is passed to the script as a variable (PATH_INFO). Not all PHP scripts use this variable, and in some server configurations it's not set properly. If you're able to access http://192.9.222.212/111/index.php (which is working properly, as it's redirecting you to the installation page) but not http://192.9.222.212/111/index.php/index/install, it's because the variable is not being properly set, which is a server configuration issue.

OJS currently requires this variable to be properly set; when the next version (OJS 2.1) is released, there will be a configuration option that doesn't require PATH_INFO (but will have uglier URLs as a result).

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Postby george_guo » Tue Dec 20, 2005 8:37 pm

Hi Hi Alec Smecher
I still cannot find how to fix this problem.
Would you please do me a favour?
Can I send my apache config file (httpd.conf) to you? You have a check with it.
thanks in advance.
my email address: debugmaster_sohu@sohu.com
george_guo
 
Posts: 4
Joined: Sun Dec 18, 2005 5:27 am

Postby asmecher » Wed Dec 21, 2005 6:45 pm

Hi George,

Have you tried enabling the AcceptPathInfo directive in your Apache configuration? Check to see if your configuration files contain this directive; if they don't, add a line like the following (and remember to restart Apache before testing):
Code: Select all
AcceptPathInfo On
If this doesn't work, please provide some more information here -- is PHP running as CGI or as a built-in module?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 7743
Joined: Wed Aug 10, 2005 12:56 pm

Postby george_guo » Thu Dec 22, 2005 12:16 am

Hi Asmecher
It works now
Thank you very much
george_guo
 
Posts: 4
Joined: Sun Dec 18, 2005 5:27 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests