You are viewing the PKP Support Forum | PKP Home Wiki

Author submissions

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Author submissions

Postby nfeasey » Wed Nov 23, 2005 1:13 pm


I can upload a submission file when I'm signed in as an author. When I click "upload", the page refreshes like nothing happened.

I am using version 2.0. Any ideas? Is this a bug?

Thank you very much.
Posts: 9
Joined: Thu Oct 20, 2005 9:01 am

Postby asmecher » Wed Nov 23, 2005 1:53 pm

Hello Nfeasey,

Here are a few things to check:
  • See what your upload file size restrictions are in PHP. From docs/FAQ:
    2) Uploads of large files fail inexplicably.

    A: This can be caused by certain Apache or PHP settings.

    Apache 2.x has a LimitRequestBody directive that, if set to a low number, can
    lead to this behaviour. In particular, the default PHP packages for recent
    versions of Red Hat Linux set LimitRequestBody to 524288 bytes in

    Low values for the PHP ini settings like post_max_size (default "8M"),
    upload_max_filesize (default "8M"), and memory_limit (default "8M") can also
    cause this problem.
  • As noted above, be sure to check your memory_limit restriction as well.
  • Check your file permissions to ensure that the web server has write access to the files directory and all of its subdirectories.
  • Turn error reporting to its maximum setting (E_ALL) in php.ini, try a submission, and check your log files for further information.

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby nfeasey » Fri Nov 25, 2005 4:45 pm

Actually the files directory had been deleted inadvertantly deleted.
Without this directory obviously file uploads did not proceed as expected. :wink:

Thank you very much for your assistance.
Posts: 9
Joined: Thu Oct 20, 2005 9:01 am

Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests