You are viewing the PKP Support Forum | PKP Home Wiki

Disabling full-text indexing when importing from OJS1

Are you an Editor, Author, or Journal Manager in need of help? Want to talk to us about workflow issues? This is your forum.

Moderators: jmacgreg, michael, vgabler, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Disabling full-text indexing when importing from OJS1

Postby arnost » Wed Jul 13, 2005 6:35 am

I have problems using tool, which imports from OJS1. It alwail fails, throwing some MySQL "Duplicate key" error.

Is it possible to switch off full-text indexing when importing from OJS1? I can't find this option.

I'd like to enable SQL debug, but it is too verbose when doing full-text indexing (it crashes my web browser :)
Posts: 5
Joined: Thu Jan 22, 2004 2:27 am

Postby kevin » Wed Jul 13, 2005 7:49 pm

That shouldn't happen, so that may indicate a bug.

Full-text indexing can be disabled through the settings in config.inc.php. Indexing of other data during import (including abstracts, authors, etc.) could be disabled by commenting the "$this->rebuildSearchIndex();" line in classes/site/ImportOJS1.inc.php. In either case the data that is not indexed will not be searchable until tools/rebuildSearchIndex.php is executed.
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm

Return to OJS Editorial Support and Discussion

Who is online

Users browsing this forum: No registered users and 0 guests