OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



error installing ojs version 2.4.2 on hosting Dattatec

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Tue Apr 23, 2013 11:00 am

after giving the permissions for the folder "cache", "public" and the file "config.inc.php" when trying to access the installation returns me the following error:
##############################################################################

Warning: require_once(classes/template/TemplateManager.inc.php) [function.require-once]: failed to open stream: No such file or directory in /home/qo000205/public_html/amanecer/lib/pkp/includes/functions.inc.php on line 30

Fatal error: require_once() [function.require]: Failed opening required 'classes/template/TemplateManager.inc.php' (include_path='.:/home/qo000205/public_html/amanecer/classes:/home/qo000205/public_html/amanecer/pages:/home/qo000205/public_html/amanecer/lib/pkp:/home/qo000205/public_html/amanecer/lib/pkp/classes:/home/qo000205/public_html/amanecer/lib/pkp/pages:/home/qo000205/public_html/amanecer/lib/pkp/lib/adodb:/home/qo000205/public_html/amanecer/lib/pkp/lib/phputf8:/home/qo000205/public_html/amanecer/lib/pkp/lib/pqp/classes:/home/qo000205/public_html/amanecer/lib/pkp/lib/smarty:.:/opt/php5/lib/php') in /home/qo000205/public_html/amanecer/lib/pkp/includes/functions.inc.php on line 30

#############################################################################

Anyone know that I do to fix it and be able to install this version of ojs?
thank you very much
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby asmecher » Wed Apr 24, 2013 7:49 am

Hi yenkys,

Check to see that there is a classes/template/TemplateManager.inc.php script and that its file permissions are correct (i.e. it can be read from a PHP script).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8815
Joined: Wed Aug 10, 2005 12:56 pm

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Thu May 02, 2013 6:36 am

I cant see this folder and script in /classes
this is all de content in the classes folder

admin
announcement
article
author
controllers
core
file
gift
handler
help
i18n
install
issue
journal
mail
manager
note
notification
oai
payment
plugins
rt
sectionEditor
security
signoff
submission
subscription
tasks
user
:?: sorry by my english, que debo hacer?
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby asmecher » Thu May 02, 2013 8:28 am

Hi yenkys,

It sounds like you are missing some files. Double-check the method you used to upload the OJS installation to your server.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8815
Joined: Wed Aug 10, 2005 12:56 pm

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Thu May 02, 2013 10:21 am

ok, thank you, i going to copy again de ojs y le digo luego que tal
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Tue May 07, 2013 11:12 am

I have copy again the ojs and verific all the permission and de file, and now i ave the new error see here
######################################################
Internal Server Error

UID of script "/home/qo000205/public_html/ojs/index.php" is smaller than min_uid
suPHP 0.7.1
#####################################################################

any idea???
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby asmecher » Tue May 07, 2013 12:28 pm

Hi yenkys,

That relates to suPHP configuration, which is outside of OJS; I'd suggest contacting your hosting provider with that error message. It's possible that your file permissions on the PHP scripts that come with OJS are set incorrectly (e.g. some hosts forbid scripts that run under 777 permissions), but it'll depend on the specifics of your host.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8815
Joined: Wed Aug 10, 2005 12:56 pm

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Wed May 08, 2013 9:02 am

Thank you very much for your help, I can now access the system installation but when I add the data from mysql data base returns me the following error.

:?

Errors occurred during installation:

A database error has occurred: Access denied for user 'ojs'@'172.17.111.122' (using password: YES)

if my data base user es qo000205, why return "Access denied for user 'ojs'@'172.17.111.122' (using password: YES)" ?

THK
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby asmecher » Wed May 08, 2013 9:09 am

Hi yenkys,

That means you have not granted the appropriate permissions linking your MySQL user account to the database you've created for OJS. OJS is trying to connect with the credentials you specified to complete the installation but cannot because MySQL is not allowing the username/password/database name combination you specified.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8815
Joined: Wed Aug 10, 2005 12:56 pm

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Thu May 09, 2013 5:25 am

Hello, sending the user name and the combination of the database on my server and use are the same for installing joomla and wordpress just changing "qo000205_joomla" I do not understand why do not work the same credentials that I have for ojs.

Thk
Attachments
error-data-base.jpg
error-data-base.jpg (91.09 KiB) Viewed 1456 times
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby yenkys » Thu May 09, 2013 7:12 am

my suportt hosting say

"Lo que no me queda muy en claro , porque segun este error , la instalacion desea
hacer la conexion a tu base de datos desde 172.17.111.122 (un host externo) para
el user ojs, intentando de esta manera una coexion remota , lo que no permitimos
en nuestros sitios alojados en servidores compartidos .-"

?????

Any idea :?:
yenkys
 
Posts: 10
Joined: Tue Apr 23, 2013 10:31 am

Re: error installing ojs version 2.4.2 on hosting Dattatec

Postby asmecher » Thu May 09, 2013 8:41 am

Hi yenkys,

Unfortunately it's not clear to me either. However, I don't suggest sharing a database -- if two applications happen to use the same table name (e.g. "users") then you will destroy your existing tables when you try to install OJS over top.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8815
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 6 guests