OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



500 or blank pages and nothing in logs

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

500 or blank pages and nothing in logs

Postby gomezalejandro » Tue Apr 16, 2013 4:36 am

My setup is as follows:
SO: Centos 6.4
PHP: 5.3.3-22.el6
Apache: 2.2.15-26.el6.centos
MySQL: 5.1.67-1.el6_3
OJS: ojs-2_3_6-0

When my hosting updates to this version of PHP, I started having 500 server error. Nothing shows in apache or php error logs. Access log is as follows:
Code: Select all
181.14.255.158 - - [16/Apr/2013:08:26:31 -0300] "GET / HTTP/1.1" 500 2012 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31"

I've searched the forum and when I add ini_set('display_errors', E_ALL); to index.php I no longer get error 500, but a 200 response with a blank page. Access log shows:
Code: Select all
181.14.255.158 - - [16/Apr/2013:08:29:21 -0300] "GET /favicon.ico HTTP/1.1" 200 2012 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31"


I've added echo "Importing " . $class . "<br/>\n"; to functions.inc.php and now i get this output:

Importing classes.core.Application
Importing lib.pkp.classes.core.PKPApplication
Importing lib.pkp.classes.core.PKPProfiler
Importing lib.pkp.classes.core.Core
Importing lib.pkp.classes.core.String
Importing lib.pkp.classes.core.Registry
Importing lib.pkp.classes.config.Config
Importing lib.pkp.classes.config.ConfigParser
Importing lib.pkp.classes.db.DAORegistry
Importing lib.pkp.classes.db.DAO
Importing lib.pkp.classes.db.DBConnection
Importing lib.pkp.classes.db.DAOResultFactory
Importing lib.pkp.classes.core.ItemIterator
Importing lib.pkp.classes.core.DataObject
Importing lib.pkp.classes.db.XMLDAO
Importing lib.pkp.classes.xml.XMLParser
Importing lib.pkp.classes.xml.XMLParserDOMHandler
Importing lib.pkp.classes.xml.XMLNode
Importing lib.pkp.classes.cache.CacheManager
Importing lib.pkp.classes.cache.FileCache
Importing lib.pkp.classes.cache.GenericCache
Importing classes.security.Validation
Importing classes.security.Role
Importing lib.pkp.classes.session.SessionManager
Importing classes.template.TemplateManager
Importing classes.search.ArticleSearch
Importing classes.search.ArticleSearchIndex
Importing lib.pkp.classes.search.SearchFileParser
Importing lib.pkp.classes.search.SearchHTMLParser
Importing lib.pkp.classes.search.SearchFileParser
Importing lib.pkp.classes.core.String
Importing lib.pkp.classes.search.SearchHelperParser
Importing lib.pkp.classes.search.SearchFileParser
Importing classes.file.PublicFileManager
Importing lib.pkp.classes.file.PKPPublicFileManager
Importing lib.pkp.classes.file.FileManager
Importing lib.pkp.classes.template.PKPTemplateManager
Importing lib.pkp.classes.plugins.PluginRegistry
Importing lib.pkp.classes.plugins.HookRegistry
Importing classes.i18n.Locale
Importing lib.pkp.classes.i18n.PKPLocale
Importing lib.pkp.classes.i18n.LocaleFile


I just don't know what to do after that.
gomezalejandro
 
Posts: 2
Joined: Mon Apr 15, 2013 9:12 am

Re: 500 or blank pages and nothing in logs

Postby gomezalejandro » Tue Apr 16, 2013 4:58 am

Update: Just upgraded to ojs-2_4_2-0 via the Full Package method and I have the same behavior
gomezalejandro
 
Posts: 2
Joined: Mon Apr 15, 2013 9:12 am

Re: 500 or blank pages and nothing in logs

Postby xurumelous » Tue Oct 15, 2013 8:19 pm

I'm stucked in this same error! I can't find the solution for this!

Can anyone help?

All my php settings are set to display errors, including config.inc.php debug options.
xurumelous
 
Posts: 3
Joined: Tue Oct 15, 2013 8:16 pm

Re: 500 or blank pages and nothing in logs

Postby asmecher » Wed Oct 16, 2013 1:06 am

Hi all,

This is almost always caused by file permission problems. See the FAQ entries on file permissions and debugging blank pages.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8575
Joined: Wed Aug 10, 2005 12:56 pm

Re: 500 or blank pages and nothing in logs

Postby xurumelous » Wed Oct 16, 2013 6:39 am

I triple checked the permissions! I "chmod -R 777" everything in an act of despair hahaha (of course, I rolled back it).

Coming to work, I had an idea to backtrace the last import call (I don't know if there is a easy way to do this with php. My last chance will be remote debug the entire script)... I will update this entry as I evolve.

Cheers!
xurumelous
 
Posts: 3
Joined: Tue Oct 15, 2013 8:16 pm

Re: 500 or blank pages and nothing in logs

Postby asmecher » Wed Oct 16, 2013 8:37 am

Hi xurumelous,

The FAQ entry on blank pages describes how to do that, in case you get lost.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8575
Joined: Wed Aug 10, 2005 12:56 pm

Re: 500 or blank pages and nothing in logs

Postby xurumelous » Wed Oct 16, 2013 7:11 pm

I just forgot to add mysql extension -.-

sorry guys!
xurumelous
 
Posts: 3
Joined: Tue Oct 15, 2013 8:16 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 4 guests