OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Possible bug when exporting XML

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Possible bug when exporting XML

Postby xerxeslin » Mon Apr 15, 2013 10:52 am

Hello all. This is my first post on the board. Unfortunately May english sucks and because of that I'm using the Google translator.

I take care of two systems OJS and decided to export the contents of a journal system 1 to system 2.

For that I chose, in system 1, option: XML export of articles and issues. This generated an XML file.

Then in system 2, I chose the option XML Import and selected the XML file that was generated by the system 1.

Issues and contents were imported, but for some reason unknown to me
  the link to some PDF files were strangers. Appears "untitled" repeatedly!!!

If permit, I could post the link here of the two systems? So could compare them.

The export and import of users worked well.

Thank you.
xerxeslin
 
Posts: 2
Joined: Mon Apr 15, 2013 10:37 am

Re: Possible bug when exporting XML

Postby asmecher » Tue Apr 16, 2013 10:00 am

Hi xerxeslin,

Where do you see "Untitled" in the imported content?
Also, what are the versions of the two OJS installations?
If you like, you can post the two links here (but please don't include any login credentials).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Possible bug when exporting XML

Postby xerxeslin » Wed Apr 17, 2013 10:17 am

Hi Thanks for the reply.

The message "SEM TÍTULO" (in English: "untitled") appears in the summary of the issue.

The version of OJS system 1 is 2.2.3.0.
The version of the system 2 is OJS 2.3.8.0.

The link to the summary without error (system 1) is:

http://www.repositorios.ufpe.br/ojs2/in ... ue/view/55

And the link to the summary that contains the message "UNTITLED" (SEM TÍTULO) (System 2) is:

http://www.repositorios.ufpe.br/revista ... sue/view/9
xerxeslin
 
Posts: 2
Joined: Mon Apr 15, 2013 10:37 am

Re: Possible bug when exporting XML

Postby asmecher » Wed Apr 17, 2013 10:24 am

Hi xerxeslin,

I can't promise this will solve the problem, but I'd strongly recommend upgrading your 2.2.3 install first -- that's a very old installation and there have been many corrections and fixes, including some to XML generation.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 3 guests