OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Internal Server Error when publishing journal issue

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Internal Server Error when publishing journal issue

Postby wheressteve » Wed Feb 06, 2013 12:57 am

Hey Guys,

I am trying to publish a journal issue.

While the table of contants is showing on the journal homepage I am receiving an internal server error on each journal link.

http://www.holisticed.org.au/index.php/IJHE/index shows the TOC of the published journal

However clicking on an article e.g. http://www.holisticed.org.au/index.php/IJHE/article/view/4

geta the following error:

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

Checking the error logs I can see the below:

==> access_log <==
124.148.189.83 - - [06/Feb/2013:06:31:16 +0000] "GET /index.php/IJHE/article/view/4 HTTP/1.1" 500 -

==> error_log <==
[Wed Feb 06 06:31:16 2013] [error] [client 124.148.189.83] PHP Fatal error: Call to a member function getDisableComments() on a non-object in /opt/bitnami/apache2/htdocs/classes/article/Article.inc.php on line 445, referer: http://holisticed.org.au/index.php/IJHE


I have no idea what might be causing this. I have checked the forums and not found anything similar.

The OJS installation is on a bitnami instance (bitnami.org). Might his be doing something funky to the URL's?

Thanks,
Steve
wheressteve
 
Posts: 4
Joined: Wed Feb 06, 2013 12:38 am

Re: Internal Server Error when publishing journal issue

Postby wheressteve » Wed Feb 06, 2013 1:04 am

Sorry.

I am using 2.3.6.0

Thanks
wheressteve
 
Posts: 4
Joined: Wed Feb 06, 2013 12:38 am

Re: Internal Server Error when publishing journal issue

Postby JasonNugent » Wed Feb 06, 2013 4:58 am

Hi Steve,

The code that is generating that error is failing because it does not have a section for the article. I would have a look at your site but it appears as though you need to be registered in order to view the table of contents. Can you confirm that the article is in a valid section? Also, if you have access to you database, there is a column called "section_id" in the articles table that should contain a number. That number should correspond to a record in the sections table.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Internal Server Error when publishing journal issue

Postby JasonNugent » Wed Feb 06, 2013 5:01 am

Something else you can try. If you can edit the file:

Code: Select all
classes/article/Article.inc.php


On line 444, change the true to false and see if that fixes the problem. I have a feeling that there may be a issue with the way caching is working on your installation.

Jason
JasonNugent
Site Admin
 
Posts: 910
Joined: Tue Jan 10, 2006 6:20 am

Re: Internal Server Error when publishing journal issue

Postby wheressteve » Wed Feb 06, 2013 4:49 pm

Thanks for the reply.

I'll give it a go and let you know.

Steve
wheressteve
 
Posts: 4
Joined: Wed Feb 06, 2013 12:38 am

Re: Internal Server Error when publishing journal issue

Postby wheressteve » Thu Feb 07, 2013 12:39 pm

Thanks Jason.

Something had happened to the sections so this fixed the error.

As an added bonus, changing line 444 from true to false, fixed some other problems I have been having.

very happy all around :D
wheressteve
 
Posts: 4
Joined: Wed Feb 06, 2013 12:38 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests