OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Error in OJS 2.4.1

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Error in OJS 2.4.1

Postby epsuiriv » Tue Jan 22, 2013 2:00 pm

Hello,

After upgrate from OJS 2.3.7 to 2.4.1 I have a lot of error messages:
WARNING: Invalid argument supplied for foreach()\n In file: /home/ojs/classes/article/Article.inc.php\n At line: 142.

Please help me understand why am I getting a PHP Warning.

Yours,
Mamun
epsuiriv
 
Posts: 3
Joined: Thu Jan 17, 2013 4:15 pm

Re: Error in OJS 2.4.1

Postby asmecher » Tue Jan 22, 2013 3:20 pm

Hi Mamun,

The message is cosmetic, but if you want to suppress it, you can apply these changes (also available as a patch here).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8676
Joined: Wed Aug 10, 2005 12:56 pm

Re: Error in OJS 2.4.1

Postby epsuiriv » Thu Jan 24, 2013 1:23 am

Thank you, Alec

Yours,
Mamun
epsuiriv
 
Posts: 3
Joined: Thu Jan 17, 2013 4:15 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests