You are viewing the PKP Support Forum | PKP Home Wiki

Batch import -- identifying problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Batch import -- identifying problem

Postby Chris_A » Tue May 09, 2006 5:59 am

I have attempted a very simple batch import using XML but get the following error:

DB Error: Field 'type' doesn't have a default value

Is this likely to be a fault in the way OJS is set up or in my XML code?
Posts: 23
Joined: Wed Apr 12, 2006 3:21 pm
Location: UK

Postby asmecher » Tue May 09, 2006 9:56 am

Hi Chris,

Have you validated your XML? If the XML validates but the import fails, it might be an OJS bug. It's most likely an empty field that requires a value (If you like, you can send your import XML to us at pkp-support@sfu.ca for more specific information.

I'd suggest double-checking to see that a mime type has been supplied for import files.

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest