OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Blank page after attempt to assign the reviewer

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Blank page after attempt to assign the reviewer

Postby Ajakss » Mon Oct 15, 2012 12:40 pm

Hi,

after attempt to assign the reviewer to the article I get the blank page. I do not know what can I do. The errors logs say it

ojs2 has produced an error Message: WARNING: Missing argument 3 for SectionEditorAction::addReviewer(), called in /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php on line 422 and defined In file: /var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php At line: 83 Stacktrace: File: /var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php line 83 Function: PKPApplication->errorHandler(2, "Missing argument 3 for SectionEditorAction::addReviewer(), called in /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php on line 422 and defined", "/var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php", 83, Array(2)) File: /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php line 422 Function: SectionEditorAction->addReviewer(Object(SectionEditorSubmission), "1") File: (unknown) line (unknown) Function: SubmissionEditHandler->selectReviewer(Array(2), Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPRouter.inc.php line 370 Function: call_user_func(Array(2), Array(2), Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPPageRouter.inc.php line 266 Function: PKPRouter->_authorizeInitializeAndCallRequest(Array(2), Object(Request), Array(2), False) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/Dispatcher.inc.php line 129 Function: PKPPageRouter->route(Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPApplication.inc.php line 180 Function: Dispatcher->dispatch(Object(Request)) File: /var/www/plain/infotezy/ojs/index.php line 65 Function: PKPApplication->execute() Server info: OS: Linux PHP Version: 5.3.3-7+squeeze14 Apache Version: Apache DB Driver: mysql DB server version: 5.1.63-0+squeeze1
ojs2 has produced an error Message: WARNING: Missing argument 4 for SectionEditorAction::addReviewer(), called in /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php on line 422 and defined In file: /var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php At line: 83 Stacktrace: File: /var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php line 83 Function: PKPApplication->errorHandler(2, "Missing argument 4 for SectionEditorAction::addReviewer(), called in /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php on line 422 and defined", "/var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php", 83, Array(2)) File: /var/www/plain/infotezy/ojs/pages/sectionEditor/SubmissionEditHandler.inc.php line 422 Function: SectionEditorAction->addReviewer(Object(SectionEditorSubmission), "1") File: (unknown) line (unknown) Function: SubmissionEditHandler->selectReviewer(Array(2), Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPRouter.inc.php line 370 Function: call_user_func(Array(2), Array(2), Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPPageRouter.inc.php line 266 Function: PKPRouter->_authorizeInitializeAndCallRequest(Array(2), Object(Request), Array(2), False) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/Dispatcher.inc.php line 129 Function: PKPPageRouter->route(Object(Request)) File: /var/www/plain/infotezy/ojs/lib/pkp/classes/core/PKPApplication.inc.php line 180 Function: Dispatcher->dispatch(Object(Request)) File: /var/www/plain/infotezy/ojs/index.php line 65 Function: PKPApplication->execute() Server info: OS: Linux PHP Version: 5.3.3-7+squeeze14 Apache Version: Apache DB Driver: mysql DB server version: 5.1.63-0+squeeze1
NOTICE: Undefined variable: request (/var/www/plain/infotezy/ojs/classes/submission/sectionEditor/SectionEditorAction.inc.php:87)



I would be very appreciate for your help.

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby JasonNugent » Mon Oct 15, 2012 1:05 pm

Hi Adam,

What version of OJS are you using?

regards,
Jason
JasonNugent
Site Admin
 
Posts: 893
Joined: Tue Jan 10, 2006 6:20 am

Re: Blank page after attempt to assign the reviewer

Postby asmecher » Mon Oct 15, 2012 1:37 pm

Hi Adam,

What version of OJS are you using?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8905
Joined: Wed Aug 10, 2005 12:56 pm

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Tue Oct 16, 2012 12:02 am

Hi,

Sorry, I forgot it. My version is 2.3.7.

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby JasonNugent » Tue Oct 16, 2012 6:09 am

Hi Adam,

I've had a look at the OJS 2.3.8 code and I don't believe that the issue you're having exists in the new version. Is it possible for you to attempt an upgrade?

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 893
Joined: Tue Jan 10, 2006 6:20 am

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Tue Oct 16, 2012 6:57 am

Hi Jason,

thanks a lot for your reply. I would like to avoid upgrading. Previously I had to start from the scratch because I have lost translations. Furthermore, I am going to publish the new issue soon and I am afraid of possible problems.

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby asmecher » Tue Oct 16, 2012 8:49 am

Hi Adam,

Are you sure there aren't modifications that might be causing this? Looking e.g. at SectionEditorAction.inc.php line 87 (or elsewhere in the addReviewer function), there is no reference to $request.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8905
Joined: Wed Aug 10, 2005 12:56 pm

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Tue Oct 16, 2012 10:35 am

Hi Alec,

the only modifications I did were recommended patches, but only a few, e.g. Bug 7410, 7233.

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby asmecher » Tue Oct 16, 2012 11:09 am

Hi Adam,

I suspect you applied the wrong patch for at least one of the recommended patches; see e.g. the comment I just posted at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=7412. Note that we actively develop on several branches of the OJS codebase at the same time, and so commit notices posted on bug entries will often refer to patches that are intended for several different branches. Applying the wrong one will cause problems.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8905
Joined: Wed Aug 10, 2005 12:56 pm

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Thu Oct 18, 2012 5:09 am

Hi Alec,

thank you for reply. I have applied only five patches (7233, 7231, 7229, 7410, 7411) for 2.3.7 version of OJS. Is there a chance that restoring old files fixes the installations?

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby asmecher » Thu Oct 18, 2012 1:17 pm

Hi Adam,

Check your browser history to see if it can tell you which patches you applied. If you can find out which specific ones it was, post the links here and I'll double-check which ones were intended for a different release. Then you can apply those -R (to reverse) and apply the appropriate ones. If that's possible, I'll clarify as I go through which patches are for which versions in the bug entries.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8905
Joined: Wed Aug 10, 2005 12:56 pm

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Sat Oct 20, 2012 11:46 pm

Hi Alec,

thanks for the reply. Unfortunately, I had to reinstall my computer and all history was lost. Is there other way to determine the applied patch?

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby JasonNugent » Sun Oct 21, 2012 7:59 am

Hi Adam,

If you're using a command line 'patch' command to apply these patches, patch will tell you if it thinks that you may have already applied a patch. You'll get a statement like 'previously applied detected!' if you try it a second time. You can run the command with a --dry-run argument so it won't actually be applied (if it hasn't already). So, if you see something like this:

Code: Select all
patch -p1 --dry-run < thePatchFile.diff
patching file ....../whatever.inc.php
Reversed (or previously applied) patch detected!  Assume -R? [n]


You'll know that this was a patch you've applied already. In such a case you can choose to reverse it.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 893
Joined: Tue Jan 10, 2006 6:20 am

Re: Blank page after attempt to assign the reviewer

Postby Ajakss » Mon Oct 22, 2012 2:04 am

Hi Jason,

thank you for excellent advice. But I have applied patches manually removing and adding relevant lines with code. Furthermore, my provider does not make avaialable the command line to management service. I am quite hopeless in this case.

Kind regards,

Adam
Ajakss
 
Posts: 55
Joined: Fri Jun 08, 2012 11:16 am

Re: Blank page after attempt to assign the reviewer

Postby springday » Mon Oct 22, 2012 3:28 am

Hi Adam,

maybe that's a bit too much work to do, but...
You could copy your entire OJS installation to a local computer with a local server software installed (for example XAMPP on a windows computer). This would also require to be able to access you web server's database to make a dump of it (for example with PHPMyAdmin). And finally you would have to get the patch tool working on your local computer. With all those things combined, you could dry-run the patch on a local machine without accessing the server's shell.

Best regards,
Kai Weber
springday
 
Posts: 111
Joined: Wed Jul 25, 2012 2:56 pm
Location: Munich, Germany

Next

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests