OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Upgrade OJS 2.2.3 to 2.3.8 Database error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Upgrade OJS 2.2.3 to 2.3.8 Database error

Postby hamsavijay » Sun Oct 07, 2012 7:46 am

We are upgrading the OJS from 2.2.3 to 2.3.8 using full install. We've unpacked all the folders of 2.3.8 in the ojs installation directory and updated the config.inc.php with the same credentials/settings as the previous version 2.2.3. Then set the installed=off mode to go through php mode and clicked "upgrade open journal system". It came with an error as below:
"A database error has occurred: Incorrect table definition; there can be only one auto column and it must be defined as a key."

Our journal is on a shared server so we have less control of SQL database and other useful tips. I wonder anyone could help us to get through this. I even attempted by restoring the database again.

PHP version 5.3.17
MySQL version 5.1.63-cll

By frustration, I've clicked again the "upgrade open journal system" and it gave me the following error:

"A database error has occurred: Table 'maftree_ijvss.copyed_assignments' doesn't exist".

I've tried searching forum and tried few options. We are struck. Please reply with the tip/trick if you have some solution.

Thanks,
Priya
hamsavijay
 
Posts: 18
Joined: Fri Jul 03, 2009 3:14 pm

Re: Upgrade OJS 2.2.3 to 2.3.8 Database error

Postby hamsavijay » Sun Oct 07, 2012 1:11 pm

I think the DB is corrupted due to few attempts - install, upgrade, upgrade etc. I've deleted the existing database at the OJS installation server and then retrieved the backedup version. After retreiving, i've reassigned the user.

Then, I've done it rightly by clicking "Upgrade" once. It came up with a message "Upgrade successful". The new version seems to group the subscriptions automatically based on provided IP into individual and instituitional subscriptions.

My query is Resolved.

Thanks for the forum.
hamsavijay
 
Posts: 18
Joined: Fri Jul 03, 2009 3:14 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests