OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Blank page after hiting install open journal systems button

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Blank page after hiting install open journal systems button

Postby lewatle » Wed Sep 05, 2012 5:32 am

I remain with Blank page in my browser after hiting install open journal systems button, this is fresh installation, i have created ojs database manually and i am trying to install over the web but this error it doesnt go away.

your assistance is greately appreciated.
lewatle
 
Posts: 4
Joined: Thu Oct 07, 2010 2:44 am

Re: Blank page after hiting install open journal systems but

Postby digilio » Wed Sep 05, 2012 7:33 am

I have a similar problem, but instead a blank page i get this error

../../datacite/classes/DOIExportPlugin.inc.php
Fatal error: Class 'DOIExportPlugin' not found in /var/www-ojs-new/plugins/importexport/medra/MedraExportPlugin.inc.php on line 24

I'm trying to install version 2.4.0
digilio
 
Posts: 4
Joined: Wed Jun 27, 2012 8:07 am

Re: Blank page after hiting install open journal systems but

Postby digilio » Wed Sep 05, 2012 8:09 am

digilio wrote:I have a similar problem, but instead a blank page i get this error

../../datacite/classes/DOIExportPlugin.inc.php
Fatal error: Class 'DOIExportPlugin' not found in /var/www-ojs-new/plugins/importexport/medra/MedraExportPlugin.inc.php on line 24

I'm trying to install version 2.4.0


I've resolved deleting medra plugin during installation
digilio
 
Posts: 4
Joined: Wed Jun 27, 2012 8:07 am

Re: Blank page after hiting install open journal systems but

Postby lewatle » Thu Sep 06, 2012 4:36 am

Good Day,

i still experience the same problem, please asnyone who have idea advise me on how to eliminate this error, the version of OJS i am trying to install is 2.4.0
lewatle
 
Posts: 4
Joined: Thu Oct 07, 2010 2:44 am

Re: Blank page after hiting install open journal systems but

Postby asmecher » Thu Sep 06, 2012 8:57 am

Hi all,

See http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=9015&p=35006#p35006.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9042
Joined: Wed Aug 10, 2005 12:56 pm

Re: Blank page after hiting install open journal systems but

Postby Radek » Tue Nov 18, 2014 12:33 am

Hi all,

I want to upgrade to ojs 2.4.5 (merged from github), but I'm still getting this similar error ../../datacite/classes/DOIExportPlugin.inc.php Fatal error: Class 'DOIExportPlugin' not found in C:\local_servers\wamp\www\ojs\plugins\importexport\crossref\CrossRefExportPlugin.inc.php on line 34

When I change crossref to datacite in import part, it's everything OK.
Code: Select all
if (!class_exists('DOIExportPlugin')) { // Bug #7848
   import('plugins.importexport.crossref.classes.DOIExportPlugin');
}

Code: Select all
if (!class_exists('DOIExportPlugin')) { // Bug #7848
   import('plugins.importexport.datacite.classes.DOIExportPlugin');
}


Am I doing something wrong?

Thank you
Regards
Radek
Radek
 
Posts: 53
Joined: Mon Jun 23, 2014 3:24 am

Re: Blank page after hiting install open journal systems but

Postby ctgraham » Tue Nov 18, 2014 7:26 am

Do you have the symbolic links from the three classes in plugins/importexport/crossref/classes (DOIExportDom, DOIExportPlugin, and PubObjectCache) to their locations in plugins/importexport/datacite/classes? c.f. https://github.com/pkp/ojs/tree/ojs-stable-2_4_5/plugins/importexport/crossref/classes
ctgraham
 
Posts: 114
Joined: Thu Apr 03, 2014 5:29 am
Location: Pitt ULS

Re: Blank page after hiting install open journal systems but

Postby Radek » Wed Nov 19, 2014 12:40 am

Yes, I do. Even I just try to use whole path, but it doesn't work too. :-/

Edit: I just downloaded whole installation of OJS-2.4.5 and there was no sym links if crossref plugin. The three classes files have theirs own whole codes. So I've copied them to my folder and replace the old files. Now it works. Thanks for help.

Regards
Radek
Radek
 
Posts: 53
Joined: Mon Jun 23, 2014 3:24 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 25 guests