OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS 2.4.0 Released

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Re: OJS 2.4.0 Released

Postby jimnull » Thu Oct 04, 2012 6:04 am

Unfortunately I don't have SSH either.
jimnull
 
Posts: 8
Joined: Mon Sep 24, 2012 8:28 am

Re: OJS 2.4.0 Released

Postby asmecher » Thu Oct 04, 2012 8:54 am

Hi jimnull,

Without SSH, the amount of maintenance you can do on your install is pretty limited. You can still use a patch-based upgrade, but it'll involve:
  • Downloading the install to your desktop computer (i.e. using FTP)
  • Applying the patch there
  • Transfering the installation back to the server.
If you do that, beware of file permissions (FTP will not preserve these), and be mindful that files that are deleted during the patching process will not be deleted on your server. (Some releases of OJS move files from one place to another, and if the old file is left in place, it can cause problems.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8316
Joined: Wed Aug 10, 2005 12:56 pm

Re: OJS 2.4.0 Released

Postby albertosa » Thu Oct 04, 2012 11:02 am

* problems updating *

Hi!
I tried to update OJS from 2.3.7 to 2.4.1. I did it in safe mode (config.inc = installed = Off). I did the OJS database upgrading via Web. After followed the steps and pressed the 'Upgrade OJS' button, I got this error:
"error: null value in column "review_round_id" violates not-null constraint."

This was not normal, I did previous updates and all ran well.

I tried to revert to old configuration but now I get this error:
DB Error: ERROR: relation "issues" does not exist
DB Error: ERROR: column "acting_as" of relation "sessions" does not exist LINE 10: acting_as = $8 ^

I cannot even access as an administrator.

The database server is PostgreSQL 8.3.

Please, how can this be solved?
Many thanks!


# note:
this subject was discussed here but without an end: viewtopic.php?f=8&t=9049
albertosa
 
Posts: 25
Joined: Fri Jul 04, 2008 9:09 am
Location: Guimarães/Braga - Portugal

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests