OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Login Failure using "Remember Me" box with IE

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Login Failure using "Remember Me" box with IE

Postby rdbartz » Thu Aug 23, 2012 12:37 am

I searched for a solution but cannot seem to get this one. Several references have mentioned it but none with a definitive solution. I hope I did my research right so that I am not guilty of posting another problem that is already solved.

OJS version 2.3.7 on a windows server with PHP 5.2.17

PROBLEM: IE Users who chect the "Remember Me" box are retuned to the login screen.

ONLY AFFECTS IE users (of course that turned out to be most of the users so far...!). If the "Remember Me" box is NOT checked, IE logs in normally, Logging in with Firefox and Chrome works perfectly no matter what. It does not matter if you use the right column login or the main one from the login page after an attempt.

Tried so far: Set session_check_ip = Off
Tried Internet Explorer in compatibility mode.
Tried it in Firefox and Chrome with and without the "Remember Me" box checked on same computer, works fine.

It looks as though the login actually is logged as successful in the database.... but it always goes back to the login page on IE if the "Remember Me" box is checked.

Suspect cookies not being set right in IE but cannot even find the OJSSID cookie someone mentioned in my Windows 7 32 bit install.

For some reason almost every one of the few users so far check that box even though they are advised not to for now. Complaining...

Anyone have any ideas here?

Thanks!
rdbartz
 
Posts: 6
Joined: Fri Mar 02, 2012 7:31 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests