You are viewing the PKP Support Forum | PKP Home Wiki

error updating database from 2.2 to

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

error updating database from 2.2 to

Postby jsnaider » Sat Jun 23, 2012 2:45 pm

we had to reinstall our OJS. The installed version was 2.2 but now we reinstalled it with the latest version 2.3.7. We followed the instructions for update (installing the full package) but when we try to upgrade the db (using the web install) it throws an error: Fatal error: Call to a member function compare() on a non-object in /www/docs/..../public_html/ojs/lib/pkp/classes/install/Installer.inc.php on line 318

If we create a new database the installation works without problems.

Any idea of how to migrate our old db to the new version??


Posts: 1
Joined: Sat Jun 23, 2012 2:30 pm

Re: error updating database from 2.2 to

Postby abdullah » Wed Oct 10, 2012 2:38 pm

Same Problem
Help Please....
Posts: 1
Joined: Wed Oct 10, 2012 2:34 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 5 guests