OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Errors after 2.2.3.0 to 2.3.7 Upgrade

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Errors after 2.2.3.0 to 2.3.7 Upgrade

Postby Effie » Thu Jun 21, 2012 1:02 pm

Hello,
After upgrading from 2.2.3.0 to 2.3.7.0, we've received these errors in our /var/log/ojs-errors.log. Should we be concerned? We have upgraded multiple journals and they all seem to have these errors.
I'm not sure what action causes the first set of errors. The last 2 errors occur when a new user registers.
Thank you,
Effie Jarrett

Code: Select all
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'a' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'em' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'strong' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'cite' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'code' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'ul' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'ol' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'li' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'dl' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'dt' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version:
 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'dd' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version:
 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'b' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version:
5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'i' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version:
5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'u' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'sup' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'sub' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'br' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index
[Tue Jun 19 10:29:24 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: USER WARNING: Attribute '' in element 'p' not supported (for information on implementing this, see the support forums) \n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/lib/htmlpurifier/library/HTMLPurifier/HTMLDefinition.php\n  At line: 324\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/index/index


[Tue Jun 19 20:11:08 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: WARNING: array_unique() expects parameter 1 to be array, null given\n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/classes/user/InterestDAO.inc.php\n  At line: 79\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/ceaforum/user/registerUser
[Tue Jun 19 20:11:08 2012] [error] [client 128.83.231.169] ojs2 has produced an error\n  Message: WARNING: array_map(): Argument #2 should be an array\n  In file: /ebs/ojs/ojs-2.3.7/cea-fe/lib/pkp/classes/user/InterestDAO.inc.php\n  At line: 82\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.3.13\n   Apache Version: Apache\n   DB Driver: mysql\n   DB server version: 5.5.20, referer: http://cea-fe-ojs-dev.tdl.org/cea-fe/index.php/ceaforum/user/registerUser
Effie
 
Posts: 5
Joined: Tue Mar 20, 2012 12:24 pm

Re: Errors after 2.2.3.0 to 2.3.7 Upgrade

Postby JasonNugent » Fri Jun 22, 2012 6:26 am

Hi Effie,

OJS 2.3.7 adds extra security to what is allowed as HTML in text fields, through a plugin called HTML Purifier. The allowed HTML tags and their associated attributes can be defined in the allowed_html setting in your config.inc.php file. I see a few items in your pasted log messages that would suggest that some of the HTML you're using on your site may contain things that aren't allowed (like that 'cite' tag). It doesn't hurt OJS, but you may notice some HTML missing in a few of your displayed fields.

The array_unique() error is a symptom of a user leaving their 'interests' field blank when they register. That's something that we should fix (but it won't cause problems on your end).

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron