OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OAI noRecordsMatch

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

OAI noRecordsMatch

Postby danilo » Wed Jun 20, 2012 4:23 am

Hi all,
I'm having problems with OAI on my OJS installation.
Although I have a journal set up with some issues, and articles in there, where I ask for OAI with ListRecords, ListIdentifiers, ecc verbs, I receive no results.

I'm using domain/index_page/oai?verb=ListRecords&metadataPrefix=oai_dc

the OAI page is shown, but the message is:


OAI Error(s)

The request could not be completed due to the following error or errors.

Error Code noRecordsMatch
No matching records in this repository


I can provide actual url via PM.

thanks in advance,
Danilo
danilo
 
Posts: 1
Joined: Wed Jun 20, 2012 4:18 am

Re: OAI noRecordsMatch

Postby allisonbrown » Tue Jan 22, 2013 3:42 pm

Hi Danilo,

I am not sure if you have fixed this yet. I was having the same problem and none of the posts I could find provided an answer. I thought it was worth sharing this in case others ran into this issue.

For us it seems to be related to OJS Version 2.3.8, while earlier versions do not need you to do this (e.g. 2.3.7 and 2.3.6)

Solution: As the Site Administrator, under the 'Journal Settings', you need to click 'Enable this journal to appear publicly on the site'.
[Location of this section is from Site Administration click 'Hosted Journals' and then click 'Edit']

This seemed to resolve the issue for us and now 'domain/index_page/oai?verb=ListRecords&metadataPrefix=oai_dc' is working for this journal

Kind regards,
Allison
allisonbrown
 
Posts: 1
Joined: Tue Mar 27, 2012 6:31 pm

Re: OAI noRecordsMatch

Postby mbria » Mon May 19, 2014 3:48 am

Thanks for the tip Allison!!

I'm migrating from 2.3.6 to 2.4.4 and this issue it's far from been obvious.
You saved my day. ;-)

Cheers,
m.
mbria
 
Posts: 316
Joined: Wed Dec 14, 2005 4:15 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 2 guests