OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



OJS database upgrade issue

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

OJS database upgrade issue

Postby yhan » Wed Jun 06, 2012 11:39 am

We have upgraded from 2.3.3-1 to 2.3.7.

While running " php tools/upgrade.php upgrade", We have encountered "[code: Installer Installer::addPluginVersions] <h1>DB Error: Duplicate entry 'refWorks-1-0-0-0' for key 1</h1>ojs2: DB Error: Duplicate entry 'refWorks-1-0-0-0' for key 1"

After upgrading the database, running "php tools/upgrade.php check" showed that "Database version: 2.3.3.1".

Is there something that the upgrade did not do (or stopped because of DB error)? How to fix this?

Thanks,
yhan
 
Posts: 30
Joined: Thu Mar 08, 2012 1:57 pm

Re: OJS database upgrade issue

Postby yhan » Wed Jun 06, 2012 1:17 pm

I know that there is a table "versions". just want to know if there are other things not upgraded because of the error.
yhan
 
Posts: 30
Joined: Thu Mar 08, 2012 1:57 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron