OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Bug in Version 2.3.7: Include the main ADODB library

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Bug in Version 2.3.7: Include the main ADODB library

Postby klbr » Wed Jun 06, 2012 8:26 am

Hi people,
after an install error message "Cannot redeclare lens_parsetest() in C:\Apache\htdocs\ojs\lib\pkp\lib\adodb\adodb-datadict.inc.php on line 23" we locate the bug in mutible require/include sequences.

The solution was to change the occurences of:
require( 'adodb-datadict.inc.php' ); --> require_once( 'adodb-datadict.inc.php' );
require( 'adodb.inc.php' ); --> require_once( 'adodb.inc.php' );
in file lib\pkp\lib\adodb\adodb-xmlschema.inc.php(96) and lib\pkp\lib\adodb\adodb-xmlschema03.inc.php(114).

The conflict is the exist of this code:
include_once(ADODB_DIR.'/adodb-lib.inc.php');
include_once(ADODB_DIR.'/adodb-datadict.inc.php');
in file lib\pkp\lib\adodb\adodb.inc.php(4034)

we use
- PHP Version 5.3.10
- apache 2.4.1

regards, klaus
klbr
 
Posts: 9
Joined: Tue Apr 27, 2010 12:06 am

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby asmecher » Wed Jun 06, 2012 8:52 am

Hi Klaus,

Is it possible that you're using auto_prepend_file in your php.ini or something similar to load ADODB for use in another application? This shouldn't happen with just OJS.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby klbr » Wed Jun 06, 2012 10:40 pm

Hi Alec
thx, my php.ini contains this lines:

; Automatically add files before PHP document.
; http://php.net/auto-prepend-file
auto_prepend_file =

regards
klaus
klbr
 
Posts: 9
Joined: Tue Apr 27, 2010 12:06 am

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby asmecher » Thu Jun 07, 2012 8:54 am

Hi klaus,

Hmm, your setup sounds pretty standard (I test with the same versions) and I've never heard of anyone running into this before. Are there any modifications you've made to the system? Could you post the full error message you were receiving (which should include the first inclusion of the problem file)?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby klbr » Thu Jun 07, 2012 10:27 pm

hi Alec

here the full logged error message:

[06-Jun-2012 11:58:33 UTC] PHP Fatal error: Cannot redeclare lens_parsetest() in C:\Apache\htdocs\ojs\lib\pkp\lib\adodb\adodb-datadict.inc.php on line 23
[06-Jun-2012 11:58:33 UTC] PHP Stack trace:
[06-Jun-2012 11:58:33 UTC] PHP 1. {main}() C:\Apache\htdocs\ojs\index.php:0
[06-Jun-2012 11:58:34 UTC] PHP 2. PKPApplication->execute() C:\Apache\htdocs\ojs\index.php:65
[06-Jun-2012 11:58:34 UTC] PHP 3. Dispatcher->dispatch() C:\Apache\htdocs\ojs\lib\pkp\classes\core\PKPApplication.inc.php:180
[06-Jun-2012 11:58:34 UTC] PHP 4. PKPPageRouter->route() C:\Apache\htdocs\ojs\lib\pkp\classes\core\Dispatcher.inc.php:129
[06-Jun-2012 11:58:34 UTC] PHP 5. PKPRouter->_authorizeInitializeAndCallRequest() C:\Apache\htdocs\ojs\lib\pkp\classes\core\PKPPageRouter.inc.php:266
[06-Jun-2012 11:58:34 UTC] PHP 6. call_user_func() C:\Apache\htdocs\ojs\lib\pkp\classes\core\PKPRouter.inc.php:370
[06-Jun-2012 11:58:34 UTC] PHP 7. PKPInstallHandler->install() C:\Apache\htdocs\ojs\lib\pkp\classes\core\PKPRouter.inc.php:370
[06-Jun-2012 11:58:34 UTC] PHP 8. InstallForm->execute() C:\Apache\htdocs\ojs\lib\pkp\pages\install\PKPInstallHandler.inc.php:70
[06-Jun-2012 11:58:34 UTC] PHP 9. Installer->execute() C:\Apache\htdocs\ojs\classes\install\form\InstallForm.inc.php:200
[06-Jun-2012 11:58:34 UTC] PHP 10. Installer->executeInstaller() C:\Apache\htdocs\ojs\lib\pkp\classes\install\Installer.inc.php:189
[06-Jun-2012 11:58:34 UTC] PHP 11. Installer->executeAction() C:\Apache\htdocs\ojs\lib\pkp\classes\install\Installer.inc.php:268
[06-Jun-2012 11:58:34 UTC] PHP 12. call_user_func() C:\Apache\htdocs\ojs\lib\pkp\classes\install\Installer.inc.php:410
[06-Jun-2012 11:58:34 UTC] PHP 13. PKPInstall->createDatabase() C:\Apache\htdocs\ojs\lib\pkp\classes\install\Installer.inc.php:410
[06-Jun-2012 11:58:34 UTC] PHP 14. NewDataDictionary() C:\Apache\htdocs\ojs\lib\pkp\classes\install\PKPInstall.inc.php:164

hope it helps a little...

regards
Klaus
klbr
 
Posts: 9
Joined: Tue Apr 27, 2010 12:06 am

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby klbr » Thu Jun 07, 2012 10:35 pm

Alec,
i just found this OJS error in php_log, it occures every 3 - 5 minutes:

[06-Jun-2012 14:37:34 UTC] ojs2 has produced an error
Message: WARNING: Missing argument 1 for PaymentManager::PaymentManager(), called in C:\Apache\htdocs\ojs\classes\payment\ojs\OJSPaymentManager.inc.php on line 35 and defined
In file: C:\Apache\htdocs\ojs\lib\pkp\classes\payment\PaymentManager.inc.php
At line: 22
Stacktrace:
Server info:
OS: WINNT
PHP Version: 5.3.10
Apache Version: Apache/2.4.1 (Win32) OpenSSL/1.0.0g PHP/5.3.10
DB Driver: mysql
DB server version: 5.5.11

regards
klaus
klbr
 
Posts: 9
Joined: Tue Apr 27, 2010 12:06 am

Re: Bug in Version 2.3.7: Include the main ADODB library

Postby asmecher » Fri Jun 08, 2012 12:21 pm

Hi Klaus,

Regarding the "cannot redeclare" error message, there's definitely something non-standard happening in your installation -- but your work-around shouldn't cause any other issues.

Rearding the other message, see bug #7229 listed at http://pkp.sfu.ca/wiki/index.php/OJS_2.3.7_Recommended_Patches. (In the future, it's better to post a single issue per thread.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests